Forum

 

Notifications
Clear all

filament runout works reverse


kekelen
(@kekelen)
New Member Registered
Joined: 6 months ago
Posts: 2
Topic starter  

Just placed a filament sensor on my Ender 3v2 but when filament is in it gives error "no filament" but if there is no filament it is working fine.

So it is reversed, and i would like to know how i can fix this.

Maybe in gcode or changing wires or something?

 

-Tested sensor with no filament in and it started to print and then added filament in the sensor and printing stops. so works reversed.

-i got an ender 3v2 with motherboard v4.2.2

-original firmware: Ender-3 V2-Marlin-2.0.1--V1.1.2-Compatible with BLTouch and filament detection.zip

-filament sensor like this one:

Originele Crelity 3D Ener 3 V2/CR 6 Se Filament Sensor Gebroken Materiaal Detectie Module Kit|3D Printer Parts & Accessories| - AliExpress

 


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@kekelen Use a multimeter to measure the limit switch inside as picture. Whether there is electricity on 1, 3 feet? And when the clip was triggered, if there is electricity on 2, 3 feet? If any of the cases is non-conductivity, that means you got a bad sensor. You have to replace it.


ReplyQuote
kekelen
(@kekelen)
New Member Registered
Joined: 6 months ago
Posts: 2
Topic starter  

@kevin

thanks for the reply but i have a completely different switch.

see attached picture


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@kekelen Sorry, I am not familiar with how to check this type of switch. You may need to ask for a replacement, but it should be the switch quality issue.


ReplyQuote