Notifications
Clear all

Ender 3 pro won't turn on


Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

I just got my ender 3 pro today and when I assembled it I tried turning it on and nothing happened. The part cooling fan just starts turning and then stops after like a second, then it starts again and stops and so on, like it's trying to turn on but can't. Other then the fan nothing else works, I checked all the connections, the motherboard and the psu and it all seems fine. And when I plug it in with a micro usb to my pc the screen turns on normally and I can access the menus and everything. Does anybody know what's going on?


ReplyQuote
Topic Tags
校工叔叔(Mr. Au)
(@nice)
Eminent Member Registered
Joined: 7 months ago
Posts: 35
 

Sounds like wrong voltage to me.  Creality printer set default voltage to 240v for safety reason.  If you are in US, you need to flip it to 120v.

When you connect the micro USB to your pc, it draw power from your computer.  Thus, the screen turns on.

This post was modified 3 weeks ago by 校工叔叔(Mr. Au)

ReplyQuote
Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

I'm not from the US, we use 240V power here, that is the first thing I checked on the psu. 

Anyway update : I got it to turn on by plugin it in straight to the wall socket (for some reason I used extension cords before). But now it's just a blue screen, even if I plug it in with micro USB. I tried reseting the firmware with a SD card but that is not working either, it's a 4.2.2. motherboard btw. I don't know, I'm very confused...


ReplyQuote
kevin
(@kevin)
Honorable Member Admin
Joined: 3 months ago
Posts: 668
 

@renchi If you turn on the print, but the always-on fan did not work, it's probably your motherboard is broken as your fan just worked/or tried to work at the beginning. 


ReplyQuote
Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

@kevin The fan is working, but it's just a blue screen.


ReplyQuote
kevin
(@kevin)
Honorable Member Admin
Joined: 3 months ago
Posts: 668
 

@renchi Ok, Let me sum up: The always-on fan is working when you turn on the printer but your screen is blue. And when you power the printer off, only use the USB cable to connect your PC, the screen could light but blue. 

That means your board should be fine, reflash the firmware for the screen should solve your problem.


ReplyQuote
Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

@kevin Is that the same for the pro as it is with the V2, with the DWIN_SET?


ReplyQuote
kevin
(@kevin)
Honorable Member Admin
Joined: 3 months ago
Posts: 668
 

@renchi Before you try the firmware, please check the wire connection for the screen! If it plugs into the EXP3?  Because this also will cause blue screen and I missed it.


ReplyQuote
Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

@kevin It is plugged in to EXP3, i also tried the 2 other connectors to see what happens, blank screen on the other two, on the EXP3 blue screen. I also tried that firmware, on a freshly formatted fat 32 sd card, i even bought a different sd card to try with the other on, no luck. As soon as i turn it on the blue screen turns on and stays like that, regardless if an sd card is in or not.

 

Btw i can run the bed leveling wizard on the creality software and everytnig works, all the motors and all the switches, even the nozzle heats up. Just that damn blue screen...


ReplyQuote
kevin
(@kevin)
Honorable Member Admin
Joined: 3 months ago
Posts: 668
 

@renchi  EXP3 is right! Do not plug into the 2 other connectors.

First, I strongly recommend you use an 8G or 16G SD card! Not sure if this is the problem. 

Then, follow this screen firmware flashing video: 

Wait, I noticed that in your first post, you said the screen could work normally and you can access the menus by using a USB cable. But now even use cable it still shows nothing but blue? 

Maybe you could try to tell the customer service your problem and let them send you a new screen.

This post was modified 2 weeks ago 2 times by kevin

ReplyQuote
Renchi
(@renchi)
Active Member Registered
Joined: 3 weeks ago
Posts: 6
Topic starter  

@kevin Just to let you know, I went to the shop I bought it from today and the guy there tried everything, he even tried a new screen but it was still blue. So they gave me a new printer, I assembled it a little while ago and everything works so yay!!

Thanks for the help tho!

This post was modified 2 weeks ago by Renchi

ReplyQuote
kevin
(@kevin)
Honorable Member Admin
Joined: 3 months ago
Posts: 668
 

@renchi We haven't started checking the motherboard yet 🤣 That is it. Anyway glad to hear you can print something now.


ReplyQuote
Scroll Up