Creality LD-002R Pr…
Clear all

Creality LD-002R Printer not Printing

3 Posts
3 Users
New Member
Joined: 7 months ago
Posts: 1
Topic starter  

I bought this slightly used from an individual who had bought it new originally. I have tried twice to print and get absolutely no print. Has new FEP, glass screen clean. How bright should the curing lights be? Even when I empty the vat and run clean vat  routine the resin in the vat is still liquid.

Active Member
Joined: 6 months ago
Posts: 8

Hi! the same thing happened to me as well! The display cable was loose and we fixed it and afterwards it prints fine. since the cable does not have a latch on the PCB side, it’s highly likely that it would’ve come off during shipping.

Active Member
Joined: 6 months ago
Posts: 16

If the print does not appear on the printing platform, nor at the bottom of the resin tank, there are a couple of possible causes: Highly insufficient exposure times. Old or separated resin. A large amount of Isopropyl alcohol (IPA) in the resin/on platform.