Forum


 

Z Home First error …
 
Notifications
Clear all

Z Home First error Ender 3 Max with BLTouch

0 Posts
1 Users
0 Likes
649 Views
0
Topic starter

Hi,

After fixing a filament jam, where I had to take off the Bowden tube to get the filament out, my printer is getting the “Z home first” error and the Z axis is refusing to move down, it will only move up. I have tried re-flashing the software after deleting the EEPROM file and every option I can think of to move the Z axis, all to no avail. the printer was printing fine before this problem.

To remove the filament jam, I heated the extruder, took off the extruder fans, took off the Bowden tube and extracted the filament. then I put it all together. No wires were pinched and the Z-Azis connector is not connected.

As I don’t think that the hardware I have touched should affect the Z-Axis, I’m a bit flummoxed. 

Any ideas would be appreciated. 

 

Update: I’m using the 4.2.2 board and standard Creality firmware.

Thinking the problem may be with the BL Touch, I bought a CR Touch and guess what, the problem is the same. Well, it’s the same after I replaced the BL Touch with The CR touch and flashed the recommended software, but I haven’t replaced the BL Touch cable. 

Having now read some other posts which seem to refer to this problem, the only solution seems to be the cable and possible electrical interference.

If this is a common, known problem, then why is there no standard “fix”. Do Creality read this forum? Do they act on it’s problems?

I’ll replace the BL Touch cable and see if that fixes the problem, but not to have a fix for a known problem is really not good enough. Having paid for an Ender-3 Max, and BL Touch and CR Touch, at this point I just have a heap of useless metal and I’m halfway through a project.

If the cable replacement doesn’t work then I’ll look at Marlin firmware, but that could be a lot of effort for little reward if it doesn’t work.

As before, any suggestions or help would be very much appreciated.

 

Another Update: I’ve loaded Marlin for Ender 3 Max and edited it for BL/CR Touch. It compiled OK and ran ok, but problem is NOT solved. So it’s a stripdown of the printer tomorrow and replace probe cable. Rapidly running out of options.

 

Last Update (I hope): Replaced the CR/BL Touch Ribbon cable and the problem appears to be solved. The Z axis is now moving normally. So, If you have this problem with an established BT Touch installation, consider replacing the CR/BL Touch ribbon cable first, it could save you a lot of angst and lost time.

 

Harry

 

This topic was modified 9 months ago 3 times by Hwal2605