Notifications
Clear all

Lost my heated bed in firmware update and homing problems

   RSS

0
Topic starter

I installed a 4.2.7 silent board & BLTouch on my Ender 3 Pro. I also updated the Marlin firmware but 3 problems remain:

(1) my heated bed does not exist on my LCD screen (Picture of my screen attached)

(2) I’m having homing issues. The first time I tried updating the firmware, the BLTouch would not home to Z and made the most horrible screeching noise. Now, it homes to Z but slams the nozzle on the board and scrapes it.  When the board homes towards the Y stepper it grinds and I have to shut off the machine. Just now, it tried to home forward - toward me and not the Y stepper and made the grinding noise until I turned it off. I saw somewhere how to update probe settings but can’t find it. I don’t can even really know if that’s the remedy...

(3) I have yet to be able to set up the BLTouch to auto level due to my homing issues. Where do I learn how to do this properly once #2 is remedied? 

Any suggestions and advice is GREATLY appreciated! I am completely new to all of this. The fact that I did the aforementioned is a HUGE miracle! So, please talk “stupid” to me! Well, dumb it down for me. I’m really not stupid. Just old-ish. 

2 Answers
0

To figure out where went wrong with the printer, could you provide some info here.

1. which firmware you used.

2. a picture that shows the BL touch circuit wiring. 

0
Topic starter

I ended up finding Marlin firmware 2.0 from Teaching Tech and flashed it in.  I also found the BLTouch from TT and flashed that in.  Everything was fixed (there were a lot of options missing from the screen menu. I realized after my initial forum post) except Z wouldn't home.  I did more research.  I possibly had a loose wire.  I hot glued my Z in properly and it homes! 

 

I attempted to level the bed with the BLTouch.  It homed and started to level. Yay! I saw "1/9" spots of leveling on the screen. Then it stopped and went to the home screen.  It only levels one spot of 9.  When looking at the bed from above it is the bottom left corner.  How do I fix, adjust, set this? 

 

As for wiring - I wired everything from my 4.2.2 board exactly as it was on to my 4.2.7 board except I wired my BLTouch exactly like the picture attached. My Z wires were loose on the board and I hot glued them. I hot glued the other BLTouch wires in their port as well to bar any loose wiring anywhere else in the future.

 

For the firmware - My E3Pro screen says "Marlin 2.0.6.1." What do you need to see?  My bin files?  It's from Teaching Tech's gumroad page.  The files that I downloaded say "Marlin-E3-427upgrade-base" and "Marlin-E3-upgrade-bltouch." Does that mean that I upgraded for and Ender 3 and not my Ender 3 Pro?  Does that make a difference? I am delirious at this point. I didn't change anything.  I compiled it as sent and it is the only thing that has remotely worked in 2 weeks.  I'll send you whatever you need to see!  I am just so appreciative for you help.  

Thanks for the feedback. You explained very well so I don't need anything else. I guess if you use the Creality BL touch and its firmware, you need an adapter board instead of put the 3pin wire into the 5pin socket.

Scroll Up