Notifications
Clear all

Ender 3 Stepper Motor issue

   RSS

0
Topic starter

Hi folks,

I've had my Ender 3 for several years and it's been a really good machine, but of late it's simply not been able to work well. I've upgraded the extruder, rebuilt the hot end, all kinds of things but, today I finally noticed that the real issue may be the stepper motor. I came across this while noticing that the motor wasn't even running properly forward while doing the 'test line' it runs on the left hand side of the print bed before a print. No material was extruded on the test line. I noticed the motor snapping back and forth, but not smoothly running forward. 

I then tried a filament extrude/retract using the change filament function and, quite simply, it couldn't do either. The filament runs free and extrudes quite nicely if I press it through by hand. Even with the extruder not under tension, the motor still isn't doing what it's supposed to.

Is the solution just to replace the extruder motor? They're not particularly expensive - but a lot of forums say that they really don't wear out - yet mine just doesn't seem to run properly anymore. All the other steppers work just fine.

Here's a vid of what it's doing:

 

More info - replaced the motor, same issue. Replaced the control cable to the motor, same issue. Switched the control cable to one of the other motors (Z Axis)  it then stuttered and behaved like the extruder motor.

Bad control board? Something else?

This topic was modified 2 months ago 2 times by Senekal
3 Answers
0

stepper motor does wear out or get damaged, especially the extruder motor, which runs more frequently than other motors. 

You can take the extruder moto cable to a different motor, like X motor, and run the extrude/retract command to see if the "new" motor works fine or not. Then you know want to do. 

Thanks for the info!

Turns out - definitely not the motor. I bought a new motor, did exactly the same thing. Changed the cable - still the same thing. Connected the cable to a different motor - same issue.

Thinking that the control board is shot?

I just notice you have an ender 3 and upgraded the extruder. Another user reported to me that after he changed to the metal extruder, the motor went wrong somehow. Was your printer good before the metal extruder? 

0
Topic starter

I wondered about that too as the tension on the metal extruder seemed higher and I thought that this might put more wear on the motor. It worked both before and after, but the problem did occur after.

The problem though, definitely isn't the motor. If the extruder caused an issue, somehow it fed back into the main board (I'm thinking). A replacement/upgrade is on the way, hopefully that will sort things out.

All that said, extruder replacement was not optional or 'just an upgrade'. The original extruder had literally worn out completely - the filament actually wearing right through the top of the in feed arm!

0
Topic starter

Well I have replaced the main board and the problem is (almost) gone. I think the issue may be partly that there is jamming up toward the hot end.

The new 'silent' board though - wow what a difference. The machine is so quiet now! My first attempt at a print didn't work, I think something got hung up on the print head and was pulled off the bed. I switched away from my glass bed to a standard one and the current print seems to be running fine so far.

And QUIET! So quiet...

Scroll Up