Notifications
Clear all

Ender 3 Head thumping X axis (HARD) Bed thumping Y axis hard post Marlin Flash - ABL install -

   RSS

0
Topic starter

Hello All,

 

First off I am sorry if this has been done before (and I've just not found it) and that I am new. I have no experience of coding/flashing/marlin and solely relied on Youtube videos and self help to get stuff done.

 

I've had my Ender 3 for a year or two now and recently got a BL Touch from Ebay. This kit is the one which came with the USBISP kit + all the usual nuts bolts/brackets. I wanted this due to upgrading the hotend as I'd like to print exotic materials for my furniture business. 

I've installed it all, got it mounted etc. I've noted the offset from the nozzle also. 

Due to wanting thermal protection and the BL Touch I used the USBISP and PROG ISP 1.72  and flashed the following:

Ender-3_8bit_1.1.6V_BL Touch Firmware_0814 (HEX)

I am told the flash was successful but even though I spent hours looking for the Ender-3 file my LCD now says Ender 3 Pro (most likely the wrong flash I presume at this stage (the issue looks almost like the build surface I have is too small. to my defence the zip and hex files do not say 'Ender 3 pro)

Note; I have the Z offset dialled near the print bed (but not near enough due to the following that seems to be the usual issue that everyone else faced but not me)

The major issue I face (& have footage of)

After getting the bed level as if to auto home, the printer then does its 28 ; ABL tasking which succeeds with no issue. however when the head homes itself towards the X limit switch, it hits it hard. with a noticeable thump. enough to send vibration through the table. This also happens on the Y carriage. (almost acting as if the limit switches do not exist at this stage)

The printer then continues to behave like normal although it looks as if the print is happening extremely close to the stock enders usually homing area (near right corner of plate)

The nozzle does not make contact with the bed at this stage but the head unit hits the X limit switch again and will vibrate itself almost to a stop as if it wants to go further than allowed & taking no notice of the limit switch.

When the head moves off of the limit switch it sounds as if the motor wants to not only go to the right but also left and fights itself. 

I've not noticed any issues with the gantry at this stage due to stopping the print etc.

 

Remedies I've tried. 

General maintenance (Tightening screws/alignment etc)

Belt tensioning

Putting the entire unit back to stock with a Z limit switch (Works as intended as if from the box)

Flashing other HEX files (the majority of which either leave the screen blank or do not have ABL or T.R.P) (the only 2 things I need as I do not at this stage want to do anything else.

 

I've put about 2 days into google/youtube and various forums (inc this one) and have not seen anything similar. (most likely phrasing issues on my part)

 

I have come here as this issue will eventually kill some components of the printer (if not done so already) 

 

I appreciate the help & anything that can be offered.

 

-Josh. 

 

 

 

This topic was modified 2 months ago by Inimical
1 Answer
0

It would be helpful if you can provide the BL Touch circuit wiring picture. I assume that your mainboard is the old board like a V1.1.4 since you said you have it for two years. There is a big chance that you may flash the wrong firmware or missed some steps during the uploading process. 

I guess there are no mechanical issues on the end stops as they worked well before?

1. you can try the firmware here.

Ender-3 _8bit_

Marlin 1.1.6 BLTouch

https://forums.creality3dofficial.com/download/ender-series/ender-3/

2. use Fronterface to send M502 code to restore the mainboard.

3. buy a new board V4.2.7 with more firmware supported. 

 

Scroll Up