Notifications
Clear all

Cura - Pause at Height problem

   RSS

0
Topic starter

Model is simple sign, with raised lettering.  Want one filament color for the base/background, second color for the lettering.

So:

  1. I am on an Ender3 V2, with 4.2.7 board.  ver 1.1.2 of the firmware (from Creality), with BL-Touch, configured, etc. (BL-Touch works fine)
  2. Load the .STL into Cura (4.9.1)
  3. Slice the model, then preview to find the layer.  Layer is in this case, 6
  4. Now go to Cura -> Extensions -> Post Process -> Modify G-Code, then “Add a script”, and add “Pause at Height”

I set everything as follows:

  • Pause at:  Layer Number
  • Pause Layer: 6
  • Method:  Marlin (M0)
  • Disarm timeout: 0
  • Park Print Head X: 190.0mm
  • Park Print Head Y: 190.0mm
  • Retraction: 5.0mm
  • Retraction Speed: 25.0mm
  • Extrude amount: 0.0mm
  • Extrude speed: 3.3333mm/s
  • Redo Layer: <blank>
  • Standby temperature: 205C
  • Display Text: Change Filament
  • G-Code before Pause: <blank>
  • G-Code after Pause: <blank>

And close the dialog with those settings

    4.  Now I reslice with the modified settings, etc. and save the model

    5.  Print the model - works fine, doesn’t seem to pause exactly at layer 6, but it DOES pause, moves the printhead to the X/Y position as set and waits.

    6.  I change the filament, get enough pushed through to clear the nozzle of the old color, and clean up before hitting the button on the controller

    7.  Hit button on controller

    8.  Head moves back into position and firmly plants itself on the glass bed so hard, it won’t move, and when the printer tries to move the either the X axis, or Y axis - flings the clip holders for the glass bed all over.  I immediately shut it off.

Result is the model is ruined, as it plants the heated nozzle straight through the model to the glass, and then makes a further mess by trying to move it.

Now, looking at the G-Code, I see:

  • M0 ; Do the actual pause
  • M109 S205 ; resume temperature
  • G1 F300 Z2.4
  • G1 F9000 X104.881 Y104.235
  • G1 F300 Z1.4 ; move back down to resume height
  • G1 F2700 ; restore extrusion feedrate
  • M82 ; switch back to absolute E values
  • G92 E64.11955

I see the line with ‘G1 G300  Z1.4’  which would move the hot end down to 1.4mm, or the sixth layer when printing at 0.2mm.  HOWEVER, I also use a  BL-Touch, and have a Z-offset of -2.55mm.  So - adding those two together gives me an actual Z of -1.55mm (even the move to a Z of 2.4mm would be “below” the print bed).  Which seems to be what I experience.  SO - is there anyway to get the “Pause at Height” to reflect the z-offset when using a BL-Touch, etc?  

Topic Tags
Scroll Up