Notifications
Clear all

Invert E0 stepper direction - Not working


sparklemotion
Posts: 8
Registered
Topic starter
(@sparklemotion)
Nozzle
Joined: 2 months ago

Hello!

I am testing out the Titan extruder on my Ender 3 Pro with the SKR Mini v2.0 motherboard. This extruder requires the extruder motor to run backwards. I tried 2x today with the custom firmware builder and neither custom firmware actually reverses the motor direction despite the Invert E0 stepper direction being checked in the firmware builder page. Any help would be great! Thanks!

 

Reply
7 Replies
3 Replies
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 3 months ago

Stepper Motor
Posts: 163

@sparklemotion Thanks for the report. Can you build the same one again and supply the Build Reference? It'll allow me to track it through the build process and see what happened...

Reply
sparklemotion
Registered
(@sparklemotion)
Joined: 2 months ago

Nozzle
Posts: 8

@marlin-firmware-service

 

here you go, thanks!!

605B23E4-4D8E-11EB-9CF4-A2463FA37987

 

Reply
sparklemotion
Registered
(@sparklemotion)
Joined: 2 months ago

Nozzle
Posts: 8

@marlin-firmware-service - reading the E3D documentation, it seems that the INVERT_E0_DIR setting needs to be flipped from whatever it is by default to the opposite:

I confirmed this while editing the bugfix version of Marlin in Visual Studio (on line 1129 as of today's bugfix build). By default, INVERT_E0_DIR is set to True. (btw I am having trouble compiling so I cannot test if this setting is working).

 

// For direct drive extruder v9 set to true, for geared extruder set to false.

#define INVERT_E0_DIR false
Reply
sparklemotion
Posts: 8
Registered
Topic starter
(@sparklemotion)
Nozzle
Joined: 2 months ago

Ok I was able to compile the current production version of Marlin (with SKR Mini v2.0 default config) and set INVERT_E0_DIR to false. I can confirm the motor does indeed run backwards now! Not sure if this is specific to this printer/mobo combo but hopefully that helps. Thanks again for a great service.

Reply
Marlin Firmware Service
Posts: 163
(@marlin-firmware-service)
Stepper Motor
Joined: 3 months ago

Sorry for the delay, I'll track down that build ID and trace it through.

Those options were only recently added - so I'm not ruling out a bug in the builder at this point.

Reply
Marlin Firmware Service
Posts: 163
(@marlin-firmware-service)
Stepper Motor
Joined: 3 months ago

Ok - after some investigation - it seems that the SKR Mini E3 V2.0 board *already* has all but the Z stepper configured to be inverted. This is now displayed properly in the builder interface.

As such, you should now be able to UNCHECK the default for INVERT_E0_DIR and it work correctly.

Reply
1 Reply
sparklemotion
Registered
(@sparklemotion)
Joined: 2 months ago

Nozzle
Posts: 8

@marlin-firmware-service thank you! I'll give it a try!

Reply
Scroll Up