Notifications
Clear all

Firmware or advice request for Ender 3 V2


VolkanOvun
Posts: 9
Registered
Topic starter
(@volkanovun)
Nozzle
Joined: 2 months ago

I subscribed to Marlin daily firmware the day before. There are really many useful firmwares but I have a problem.

As I told in topic head I have an Ender 3 V2 with 4.2.2 board. I added a BLTouch, which has an adapter, using screen port. BLTouch works fine with official firmware, which is released in Creality's website as "BLTouch with adapter". My problem is, I also want to use a filament runout sensor as well. But, BLTouch does not work with the firmware which I downloaded from Marlin's daily firmware service. I'm not an expert but I guess it's because my BLTouch is with adapter. 

 

May I request a firmware which may allow me to use filament runout sensor and BLTouch with adapter together please?

 

Thanks for help.

Reply
6 Replies
Marlin Firmware Service
Posts: 192
(@marlin-firmware-service)
Stepper Motor
Joined: 4 months ago

Don't use the adapter. The v4.2.2 and v4.2.7 boards all have a dedicated PROBE port which should be used instead.

Reply
5 Replies
VolkanOvun
Registered
(@volkanovun)
Joined: 2 months ago

Nozzle
Posts: 9

@marlin-firmware-service Thanks for reply.

 

Yes, I noticed that and tried skip the adapter. I plugged in the screen cable normally and BLTouch's cable into dedicated port, colors as shown. Smoke and burn smell appeared. I turned off the printer immediately, luckly MB not fried yet but for sure a component got weak. Now I do not have sufficiant courage to try different colors on different pins.

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 4 months ago

Stepper Motor
Posts: 192

@volkanovun Check the FAQ for the correct wiring... A lot of people (even me!) get it wrong the first time... Thankfully, its normally not fatal as long as you correct this quickly....

https://marlin.crc.id.au/faq/Ender%203%20V2/#bltouch

Reply
VolkanOvun
Registered
(@volkanovun)
Joined: 2 months ago

Nozzle
Posts: 9

@marlin-firmware-service

Thank you. 1 hour ago I noticed that red and blue cables replaced in adapter pins (they were red-blue-yellow....). I re-positioned them as blue-red-yellow-black-white and connection is correct now without any board fry. 

Now my new problem is, Z-Offset does not response for bed adjustment. I read FAQ, saw the answer but as an old moron ( 🙂 ) did not understand what to do. There written the solution is for octoprint, should I write these Mxxx codes in Cura? I have no idea.

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 4 months ago

Stepper Motor
Posts: 192

@volkanovun If you use Octoprint, you can type the M/G code in the OctoPrint terminal. Otherwise you will need Pronterface to do it properly.

Pronterface allows you to talk directly to your printer via USB.

Reply
VolkanOvun
Registered
(@volkanovun)
Joined: 2 months ago

Nozzle
Posts: 9

@marlin-firmware-service

Thanks for explaination. I don't use OctoPrint and don't know anything about Pronterface. I'll dig internet to learn something about it. If I got stucked, I'll ask you again, if you don't mind.

Reply
Scroll Up