Notifications
Clear all

Ender 3v2 400x400 bl touch


jdumais
Posts: 4
Registered
Topic starter
(@jdumais)
New Member
Joined: 3 months ago

Has anyone been able to successfully build a marlin 2.0 firmware with the above mentioned specs?

 

I have tried several times to no avail, I can get it to compile, but it does not work correctly when tried on the printer.

 

I'm also having issues with the printer freezing using the creality firmware Ender-3-v2_32bit_4.2.2_BLTouch_Marlin-2.0-V1.1.1

 

Reply
9 Replies
1 Reply
Ran
 Ran
Registered
(@ran)
Joined: 3 months ago

New Member
Posts: 2

@jdumais Were you able to resolve this? I have similar issue. E3v2 400xl w/ BLTouch. I tried Marlin Firmware Service builder but none of the service builds have worked in that the bltouch in bilinear -5 only probes one point, at the x home.

Reply
Marlin Firmware Service
Posts: 209
(@marlin-firmware-service)
Estimable Member
Joined: 7 months ago

What do you mean by 'does not work correctly'?

It's likely that its a combination of settings that are incorrect when you do the custom build vs what you're expecting.

Reply
7 Replies
Ran
 Ran
Registered
(@ran)
Joined: 3 months ago

New Member
Posts: 2

@marlin-firmware-service in my instance the auto home and z offset process work proper but the leveling feature only probes once at the X home sensor position. Ive made the builds with and without other features and with bilinear set as default 3 but cannot get leveling to cooperate. Any suggestions are appreciated!

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 7 months ago

Estimable Member
Posts: 209

Check to see if you are issuing a G29 command to do the leveling - not G28.

G28 will only probe once in the centre to get a home position. G29 will do the actual probing.

Reply
jdumais
Registered
(@jdumais)
Joined: 3 months ago

New Member
Posts: 4

@marlin-firmware-service

I mean the system does not seem to recongnize the 400x400 bed even tho i change the config to 400x400, the bltouch would only do the auto home and then once the extruder got up to temp the percentage would count up really fast and then say it was done printing, yet nothing moved.

 

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 7 months ago

Estimable Member
Posts: 209

@jdumais Can you move the bed via the control panel?

I'm starting to think that maybe the end-stops aren't functioning. Here's how you could test them:

Reply
jdumais
Registered
(@jdumais)
Joined: 3 months ago

New Member
Posts: 4

@marlin-firmware-service

I can confirm the end stops are working. I have the pre-compiled creality firmware in my machine now and its working, but my BLtouch only does a level on the original 220 x 220 size, not the 400 x 400

 

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 7 months ago

Estimable Member
Posts: 209

@jdumais Interesting.... A good debugging step would be to try a print or move via the USB port and see what error comes up for each move command...

I'm sure Marlin won't be silent about it, but you won't see any of that if printing from the SD Card...

Reply
jdumais
Registered
(@jdumais)
Joined: 3 months ago

New Member
Posts: 4

@marlin-firmware-service

Would you mind scanning over the config to see if you see anything wrong?

 

Reply