Notifications
Clear all

Ender 3 V2 ,v4.2.7 MB, Bltouch, Hemera, Firmware didn't work, printer wont go down to bed.

Page 1 / 2

cordero808@yahoo.com
Posts: 4
Registered
Topic starter
(@cordero808yahoo-com)
New Member
Joined: 6 months ago

Hello,

I have a membership with

and i tried the firmware builder and the firmware caused the printer to Z0 out 28 MM above the bed. And no matter what I do I can't get it to go down or print on the Glass bed. I then tried the walkthrough on the E3d website to compile my own and I still have the same issue. Can anyone help me I don't know what I am doing wrong. I attached my precompiled file and an pic of my rig. The BL touch is exactly 68mm directly behind the nozzle. I have reached out to E3d but I don't know if they will do anything.

>>> M503
SENDING:M503
echo: G21 ; Units in mm (mm)
echo:; Filament settings: Disabled
echo: M200 S0 D1.75
echo:; Steps per unit:
echo: M92 X80.00 Y80.00 Z400.00 E409.00
echo:; Maximum feedrates (units/s):
echo: M203 X500.00 Y500.00 Z5.00 E25.00
echo:; Maximum Acceleration (units/s2):
echo: M201 X500.00 Y500.00 Z100.00 E1000.00
echo:; Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo: M204 P500.00 R500.00 T1000.00
echo:; Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
echo: M205 B20000.00 S0.00 T0.00 X10.00 Y10.00 Z0.30 E5.00
echo:; Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:; Auto Bed Leveling:
echo: M420 S0 Z10.00
echo:; Material heatup parameters:
echo: M145 S0 H185 B45 F255
echo: M145 S1 H240 B70 F255
echo:; PID settings:
echo: M301 P28.72 I2.62 D78.81
echo: M304 P462.10 I85.47 D624.59
echo:; Power-Loss Recovery:
echo: M413 S0
echo:; Z-Probe Offset (mm):
echo: M851 X0.00 Y24.00 Z0.00

Reply
8 Replies
Marlin Firmware Service
Posts: 209
(@marlin-firmware-service)
Estimable Member
Joined: 7 months ago
Posted by: @cordero808yahoo-com

echo:; Z-Probe Offset (mm):
echo: M851 X0.00 Y24.00 Z0.00

You might well need to update these for the new offset. It's likely the probe is triggering on either something not the bed, you have your Z-Stop still connected, or something else along those lines.

If you do a G28 (home), does it bring the BLTouch down to the bed?

Reply
cordero808@yahoo.com
Posts: 4
Registered
Topic starter
(@cordero808yahoo-com)
New Member
Joined: 6 months ago

No zstop. With the g28 it trys to go down and then just stops in mid air and the bltouch doesnt change color like when it touches the bed. Its really weird.

Reply
inigoml
Posts: 6
Registered
(@inigoml)
Active Member
Joined: 2 months ago

Same problem here with Ender 3, bltouch firmware and board 4.2.2. BLprobe does not touch the bed.

This only happens with firmware builder. With prebuilt daily firmware there is no problem and it's working properly.

Reply
2 Replies
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 7 months ago

Estimable Member
Posts: 209

@inigoml If it only happens on the builder, its likely an incorrect option being selected...

Ensure you have the "Use Probe for Z homing" option selected, and you have the correct port (probe or z-stop) selected as well.

Reply
inigoml
Registered
(@inigoml)
Joined: 2 months ago

Active Member
Posts: 6

@marlin-firmware-service Yes, only happens with firmware builder. Definitively, I will test more. But I've tested also with defaults (I assume it would be the same that regular build), but not tested with many options.

Reply
inigoml
Posts: 6
Registered
(@inigoml)
Active Member
Joined: 2 months ago

These are my settings.

Now it's touching bed properly but first probe point is out of bed and stops. I cannot adjust Z_MIN_POS, X_MIN_POS and Y_MIN_POS because compilation error (no log) and since I cannot tell firware by Z_PROBE_OFFSET there is no way to use custom builder firmware... but... no problem with prebuilt one! 🙂

 

Reply
1 Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 7 months ago

Estimable Member
Posts: 209

@inigoml It seems like you need to set an X and Y offset using the M851 command.

This is the PROBE offset and should not be confused with the HOME offset...

Reply
Page 1 / 2