Forum


 

CR-10 V3 BL touch a…
 
Notifications
Clear all

CR-10 V3 BL touch and firmware update issues

5 Posts
4 Users
2 Likes
1,537 Views
That1WeirdSarja
Posts: 1
Topic starter
(@that1weirdsarja)
New Member
Joined: 1 year ago

recently bought the CR-10 V3 and had a lot of issues leveling the bed, to the point of leaving permanent scratches on it.

to avoid doing any more damage, I acquired a BL touch kit from Creality, and for the last 6 hours have tried to install and use it.

I watched many tutorials, and all of them go through the Creality slicer and pick (Under the “Communication settings”) COM something instead of the default “AUTO” setting.

I CAN’T DO THAT APPARENTLY! 

 

the option simply never popped up. ever.. 

 

I tried using ten different cables to connect it to my laptop (Lenovo Ideapad 720), updated plenty of drivers, installed many .cn files from windows that were supposed to somehow help (one actually disabled my keyboard for half an hour and I had to use a restore point to fix it), etc etc etc… I finally found my COM thing after installing it from the “Install legacy firmware” option, in the windows device manager. (and yet the slicer never acknowledged its existence).

I saw a lot of folks talking about Arduino in this context, and yet I have no idea how Arduino has anything to do with 3D printing – even so, when I used to make projects with it I never had any sort of issue with the Serial ports. (I did install the CH34 driver once on a computer in my school {and now trying to fix this issue} but nothing else)

 

I honestly just need a comprehensive guide here, what exactly should I do and how did I screw it up so badly?

As I’ve stated, since I can’t really level the bed the printer isn’t in use and won’t be until I figure this out, so ill appreciate any and all suggestions. 

 

 

 

 

Reply
4 Replies
1 Reply
Bruster
(@bruster)
Joined: 1 year ago

New Member
Posts: 1

@that1weirdsarja
You will need to find the CH341 driver for your computers USB, had the same issue with my friends CR10 V3. Wouldn’t talk to the computer but once we installed the driver (may have to do it as admin) we were able to talk with pronterface, cura, prusa
You will have to go to device manager and check the com ports to see which port got assigned to the USB and change the baud rate to 115K and you should be good to go.
As for the firmware, i would be a bit leary on trusting that it was set up correctly. They are saying to use the CR10 V2 which is a bowden and if you have a V3, it is a direct drive which has different Esteps, retraction settings etc.

Reply
kevin
Posts: 1045
(@kevin)
Noble Member
Joined: 2 years ago

I rarely see the tutorial for CR-10 V3, upgrading on these kinds of machines is dangerous. I recommend you learn well how to manually leveling your bed, even if your bed is not flat, it is much easier to change a new build plate than installing a BL touch.

Creality did a mess on firmware because they release new products too frequently and they did not pay enough attention to service. In many cases, when the users buy the upgrade accessories and trying to upgrade their machine, there is no correct firmware or the motherboard underlay file did not support this upgrade. Such as the touch screen upgrade on Ender 3, you have to change the mainboard together.

So, I really recommend you go manual bed leveling. I like this live bed leveling method very much! and it is the best way to make sure whether your filament will stick on the bed. 

https://www.youtube.com/watch?v=_EfWVUJjBdA&t=303s

Reply
1 Reply
zuasive
(@zuasive)
Joined: 9 months ago

New Member
Posts: 2

@kevin is right. There is NO replacement for knowing how to level your bed! Additionally, historically flashing firmwares has been a “challenge” if not disastrous. Especially if you flash firmware that doesn’t have the correct communication drivers. If you’re not familiar with JTAG or other methods to connect to hardware you’ve bricked it.

Reply
zuasive
Posts: 2
(@zuasive)
New Member
Joined: 9 months ago

Bruster is right, go here and download this driver.

http://www.wch-ic.com/downloads/CH341SER_EXE.html

**INSTALL THIS FIRST!**

Now make sure you have installed the Creality flavored cura. Additionally, make sure you have a really good quality micro-usb cable. They will be thicker, it needs all the connections in order to communicate with the serial device.

1.) Turn off and unplug your printer.

2.) Connect your USB cable to your computer and printer

3.) Open the device manager on your computer and check the “Ports (COM & LPT)

    a. You should either see CH340 or Serial Interface

    b. Hopefully it has the com port labeled in the name (COM4) is an         example. If not you will need to look at the properties and determine the   com port number.

4.) Open the Creality slicer software and go to Machine and then Machine Settings. In there you set the Communications Settings to the COM*

5.) Finally go to Machine and select Install Custom Firmware. Select your firmware (.hex) that you downloaded. You will get a warning message about ATMega (A serial communications device), just click ok and it will flash the firmware.

It is easy and smooth, I did it in 5 minutes after finding Bruster’s driver post here. BLTouch firmware flashed and good to go!

Reply