Notifications
Clear all

Change filament load speed is too high


inigoml
Posts: 6
Registered
Topic starter
(@inigoml)
Active Member
Joined: 3 weeks ago

Prebuilt Ender 3 4.2.2 firmware load rate is too high. Filament slides on extrusor gear and eventually can break or cause some kind of clog. So, I have to load manually always.

We cannot change load feedrate from firmware builder. So, we should add a new option for these or eventually reduce load feedrate at least by a half in order to avoid this problem.

Thank you!

Reply
Topic Tags
4 Replies
4 Replies
kevin
Admin
(@kevin)
Joined: 3 months ago

Honorable Member
Posts: 668

@inigoml Good point! And hope to update soon.

Reply
inigoml
Registered
(@inigoml)
Joined: 3 weeks ago

Active Member
Posts: 6

@kevin Thank you very much!

By now, I only use unload filament that has no problem and load is performed by moving extruder engine from motion menu.

The main problem is when changing filament in the middle of a print task in order to swap colors, for example. Cura pause or file replacement option call change filament command and so you have to be careful to keep filament out of printer and insert them by hand later. I can live with it for now but it would be great to provide customization for this in firmware builder and low speed for regular daily builds.

Reply
kevin
Admin
(@kevin)
Joined: 3 months ago

Honorable Member
Posts: 668

@inigoml

It would be nice if you could write code yourself..

Reply
inigoml
 inigoml
Guest
(@inigoml)
Joined: 2 weeks ago

Posts: 1

@kevin If firmware builder code is public and knowing what setting to change, should be easy for me. I've plenty experience in PHP and C/C++ and Perl. Phyton should not be a problem also.

Reply
Scroll Up