Notifications
Clear all

Filament runout sensor problem


VolkanOvun
Posts: 9
Registered
Topic starter
(@volkanovun)
Nozzle
Joined: 3 months ago

I have an Ender3 V2 printer with 4.2.2 MB. I also attached a BLTouch and filament runout sensor. I use Marlin daily firmware, BLTouch fine now but filament runout sensor works reverse. I mean, it works when no filament inside but stops when filament loaded. It's a simple chinese sensor, probably there is a micro switch inside. Logically there must be a C, NormalOpen and NormalClose pins and if I replace NO and NC pins, it should work fine... But logic did not work. After I replaced pins, blue led always lit (with & without filament) and extruder does not feed filament.

I added Cura's start G-Code M412 S1; then M412 D35. When sensor loaded with filament blue led lit, printer stops and unload filament all the way out ignoring M412 D35 code.

I'm happy with latest daily firmware, BLTouch checks the bed in 25 points, I see X, Y, Z positions on screen etc. May I request a firmware which make my filament runout sensor work properly.

Thanks.

Reply
6 Replies
6 Replies
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 5 months ago

Stepper Motor
Posts: 195

@volkanovun The nightlies only support the Smart Filament Sensors.

For the cheaper microswitch ones,  you'd need to create a custom firmware via the Builder.

https://marlin.crc.id.au/builder/

Select the Filament Runout Sensor option, but do not select the Motion Based Sensor option. You'll need to select your signal level for the sensor you use and how its wired. This seems to be different for each sensor.

Reply
VolkanOvun
Registered
(@volkanovun)
Joined: 3 months ago

Nozzle
Posts: 9

@marlin-firmware-service

Thank you for leading me. Unfortunately I couldn't make it. Filament runout sensor problem placed in second row, because BLTouch does not work properly. When I select autohome, head goes to middle of the bed and hang above there, does not level and check the bed. When I select auto bed leveling, head goes to left down corner of the bed, prepare to level with blue led but does not go all the way down, moves only a few milimeters and then stops, hangs above. 

On the other hand I noticed when power goes, printer can not recover.

I went to firmware in creality's site, download latest firmware with BLtouch but it also does not recower wnen power goes. Wity very early firmware when I bought printer, in case power loss I was seeing "unexpected power error" on screnn and I could continiue. I'm highly disappointed. 

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 5 months ago

Stepper Motor
Posts: 195

@volkanovun Normally, strange BLTouch behaviour like that is a case of wiring problems.

Check the FAQ and make sure you have the wiring correct - and that you've removed your Z-Stop. It isn't used anymore.

https://marlin.crc.id.au/faq/

As for the power off recovery, it is available, but you have to turn the option on. By default, its turned off as it causes massive amounts of wear on the SD Card causing them to fail much, much quicker.

See the Marlin documentation on how to enable:

https://marlinfw.org/docs/gcode/M413.html

Reply
VolkanOvun
Registered
(@volkanovun)
Joined: 3 months ago

Nozzle
Posts: 9

@marlin-firmware-service

Thganks for reply and directions. Since I'm very very new at 3D printing stuff I'm not %100 sure but I guess BLTouch witring is correct now, because it works with daily firmware. Autohome normally and checks from 25 points before starting to print. But when I try to create my own firmware it doesn't work. I select BLTouch and ten I tried all following combinations

** Use Z stop port for probe

** Use Z stop port for Probe + Use Probe for Z Homing

** Use probe port for probe (this shoud work because 3+2 pins are on dedicated port)

** Use probe port for probe + Use probe fro Z homing 

Unfortunately none of them worked.

 

When I solve BLTouch problem, then I'll try to solve cheap filament runout sensor problem. 

 

I guess I can not able to solve power loss thing since I can not modify firmware. If I could modify, never need to subscribe and pay to daily build.

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 5 months ago

Stepper Motor
Posts: 195

@volkanovun Here is the equivalent options for the Builder as the nightly builds:

 

 

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 5 months ago

Stepper Motor
Posts: 195

@volkanovun I also think you misunderstand regarding the power loss... The documentation says to use:

M413 S1

This option can be added to your Slicers Start G-Code to enable it.

Reply
Scroll Up