Forum


 

Cannot set BL Touch…
 
Notifications
Clear all

Cannot set BL Touch probe Z-offset

5 Posts
3 Users
0 Likes
5,680 Views
BananaBanshi
(@bananabanshi)
New Member
Joined: 2 years ago
Posts: 3
Topic starter  

I installed a BL Touch on my Ender 5 Pro with a v2.2 board and the latest firmware.

Everything is working as expected, except that the nozzle is 2.1 cm too high when bed leveling or trying to print, and it is impossible to set the probe Z-offset to correct this problem.

I have tried everything I can think of, including compiling custom firmware based.on the most recent Marlin version, but can’t get the BL Touch to respond properly.

Any help would be greatly appreciated.

BTW, is it possible to get ahold of the source for the firmware posted on this site? It might help…


   
ReplyQuote
(@eli-liu)
Member
Joined: 2 years ago
Posts: 462
 

I believe this video is helpful. for more info, you can view the tutorial scetions.

https://youtu.be/y_1Kg45APko


   
ReplyQuote
BananaBanshi
(@bananabanshi)
New Member
Joined: 2 years ago
Posts: 3
Topic starter  

@eli-liu Thank you! That was exactly what I needed to know. 

For anyone else with this issue:

* Use the official Creality firmware for BL Touch on your printer. (You don’t need custom firmware.)

* Start up your printer and wait for info screen.

* Plug your printer into your computer.

* Start up Pronterface and connect to your printer.

* Follow the instructions in the video.

* Thank eli-liu and Joe aka Breaks’n’Makes!


   
ReplyQuote
(@mattyp713)
New Member
Joined: 2 years ago
Posts: 4
 

I just installed the BLTouch today. I was trying to get it calibrated, and found that I do not have the Z-Offset setting on my printer.

Anyone have any idea why this setting would be hiding from me?

Ender-3 Pro 4.2.7; Marlin 2.0.1v1.1.2


   
ReplyQuote
BananaBanshi
(@bananabanshi)
New Member
Joined: 2 years ago
Posts: 3
Topic starter  

@mattyp713

This setting is probably not available unless you replace the default version of the firmware with the BLTouch version. (Apologies if you already did this.)

You should be able to find it under “Control”->”Bed Leveling”->”Z-Offset”.


   
ReplyQuote