Forum


 

Notifications
Clear all

[Solved] Extruder running in reverse after cr touch install with new firmware

39 Posts
29 Users
4 Likes
3,809 Views
c4pete
(@c4pete)
New Member
Joined: 10 months ago
Posts: 3
Topic starter  

Hi, I’ve had my 5 pro for a month or so now, all working fine and decided to add the CR touch auto bed levelling.  My board is the 4.2.2 board and I installed the CR touch and upgraded to the “Ender-5 ProMarlin2.0.6HW4.2.2ALTE137” firmware from the creality.com website.  I did an EEPROM reset after firmware update as per instructions.  All seemed fine and I set my Z offset without any issue.  Then I came to print, and no filament was coming out of the hot end, then I realised the extruder drive is running backwards.

Doing some googling it seems like the update from my original firmware moved me from a firmware based on Marlin1 to one based on Marlin2, and this for some reason means the extruder drive runs backwards unless you re-compile the firmware with INVERT_E0_DIR reversed in the Configuration.h file.  Problem is creality firmware source is not available, so my printer now will not print using the firmware provided by creality.


   
ReplyQuote
c4pete
(@c4pete)
New Member
Joined: 10 months ago
Posts: 3
Topic starter  

Just wanted to update anyone interested that I raised a support ticket and received an updated firmware via email next day, which solved this issue. 

I’ve attached the bin file to this post in case it helps anyone.  Reminder: this is for Ender 5 Pro with CR Touch and mainboard version 4.2.2.

This post was modified 10 months ago by c4pete

   
Difray reacted
ReplyQuote
HangManUK
(@hangmanuk)
New Member
Joined: 10 months ago
Posts: 1
 

Hi, do you have a copy of the firmware? You said you attached it but I can’t see it.  Mine is doing exactly the same.  I have also had to adjust the probe offset for the x axis to +4 which wasn’t mentioned in the instructions.  Other forums were suggesting -4 so wondered if other settings are opposite also?

 


   
BondiBen reacted
ReplyQuote
BondiBen
(@bondiben)
New Member
Joined: 9 months ago
Posts: 1
 

I have the same problem with my Ender 5pro


   
ReplyQuote
dubbySwords
(@dubbyswords)
New Member
Joined: 9 months ago
Posts: 2
 

I have the ptoblem too. @c4pete can you attach the bin file.


   
ReplyQuote
dubbySwords
(@dubbyswords)
New Member
Joined: 9 months ago
Posts: 2
 

I have the problem too. @c4pete can you attach the bin file.


   
ReplyQuote
TSRD
 TSRD
(@tsrd)
New Member
Joined: 9 months ago
Posts: 1
 

Same problem after flashed firmware Ender-5 ProMarlin2.0.6HW4.2.2ALTE137.bin on ender 5 pro 4.2.2 MB and installed CR touch. Already sent a request to creality support


   
ReplyQuote
Dennis123
(@dennis123)
New Member
Joined: 9 months ago
Posts: 1
 

Same here, searched multiple sites and found change something in .bin file. But could not open .bin file, after installing Visual Code I could open the file, but couldn’t find the mentioned lines ☹ 

So an updated firmware file would be nice ? @c4Pete 

 

BTW, my CR-touch crashed into the Y axis and had to set an offset on the X axis of 35 after installing the 4.2.2 firmware. After this was solved, if found the extruder was running backwards and so no printing possible. I would like to solve it without changing wires if possible


   
ReplyQuote
Robertasbill
(@robertasbill)
New Member
Joined: 9 months ago
Posts: 1
 

Did this firmware file get posted by Creality?

 


   
ReplyQuote
Peter
(@pemuldergmail-com)
New Member
Joined: 9 months ago
Posts: 3
 

can anyone share the updated firmware from Creality?

(also having same issue here……)


   
ReplyQuote
momo77
(@momo77)
New Member
Joined: 8 months ago
Posts: 1
 

Just purchased ender 5 pro V4.2.2 and cr touch and I too am having the same problem of the extruder running the filament backwards.  If any was able to get the correct firmware could they please share?  I also tried to flash the motherboard with the original firmware with the only one that seems to be correct (V4.2.2) on the Creality download website is in Czech.  Any suggestions?


   
ReplyQuote
Peter
(@pemuldergmail-com)
New Member
Joined: 9 months ago
Posts: 3
 

@tsrd you received an updated firmware file?

..can you please share 😉


   
ReplyQuote
Peter
(@pemuldergmail-com)
New Member
Joined: 9 months ago
Posts: 3
 

found this link Ender-5 Pro Firmware & Files – Creality 3D Printing Resources Forum (creality3dofficial.com) and the firmware Ender-5 Pro-V4.2.2–32bit Marlin2.0.1 – V1.1_BL-Touch(without adapter board) works, but is not the latest Marlin version…

…still interested in the version received from creality after support call 😉


   
ReplyQuote
Philip
(@philip)
New Member
Joined: 8 months ago
Posts: 1
 

Also here the same problem. 


   
ReplyQuote
Kvasir007
(@kvasir007)
New Member
Joined: 8 months ago
Posts: 2
 

I am having the same problem after installing the CR touch.  The “Ender-5 Pro_32bit_Marlin2.0.1 – V1.1_TMC2208.BL Touch_Firmware_0814” firmware seems to work and I am able to get the CR touch to work (sort of), but the 1.1.1 firmware is not as good as the 1.2.1 I was using before adding the CR Touch.   Most importantly the option to Change Filament is missing from 1.1.1

 

I would love to get the most current.  (Downloading and compiling Marlin is not high on my todo list this week.  lol) 


   
ReplyQuote
Page 1 / 3