Notifications
Clear all

Ender 5 Pro Homing Failed


benzoenie
(@benzoenie)
Screw Registered
Joined: 2 months ago
Posts: 1
Topic starter  
When first starting up my new Ender 5 Pro I had the error "TMC Connection Error". On the forums I saw to update the firmware. Under Creality's downloads  page I downloaded "Ender-5 Pro 4.2.7mainboard (32bit).zip" 
I loaded: Ender-5 Pro 4.2.7mainboard (32bit) > Marlin2.0.1 V1.0.1 original versionTMC2225 > Marlin2.0.1 - V1.0.1 - Endstop -TMC2225.bin onto SD card and into the pinter. It fixed the problem. 
 
But now:
When I try to autohome I get the message "Homing Failed: PRINTER HALTED Please reset". I can't get passed this. Connections are tight and in the right places. Belts and wheels are on solid but not too tight.
The Y stop came broken in two but I think I fixed it, and I figure X would still home if that was the problem.
Creality's customer service won't get back to me.
Please help!

ReplyQuote
Eli liu
(@eli-liu)
Power Supply Customer
Joined: 7 months ago
Posts: 462
 

Firstly, you need to check the printer's mainboard version, see if it is 4.2.7 or 4.2.2.

If the firmware version was correct, you can try to use a computer and a gcode sender software like pronterface to home the printer.


ReplyQuote
grumpy_critter
(@grumpy_critter)
Screw Registered
Joined: 2 months ago
Posts: 1
 

having an issue with homing failing as well but its one setting i cant change because of sanity check any help would be greatly appreciated. 

 So everything was working then updated firmware marlin 2.0.7.2 now im at an issue where all axis move the direction they are supposed to but when i do homing my bltouch probe extends like it should but the z goes in wrong direction. i have tried the simple fix where changing

#define X_HOME_DIR 1
#define Y_HOME_DIR 1
#define Z_HOME_DIR 1 from -1 to correct but upon compiling it says just need to fix this....

#error " z_home_dir must be -1 when homing z with probe. so how the hell can i fix that when it wont let me thats the only issue as when not homing z axis moves the proper way its just when i probe it wont so reversing polarity will not correct. if i could get it to just take that define z_home_dir 1 it would work fine but that damn error

Machine ender 5 pro microswiss dd and hotend

Btt skr 1.4 turbo and touch screen

tmc2209 running sensorless. <-- works fine just cant do the damn z direction i need on homing


ReplyQuote
Scroll Up