Forum

 

Notifications
Clear all

Layer Shift, Ender 3 V2

Page 16 / 25

gozo
 gozo
(@gozo)
New Member Registered
Joined: 1 year ago
Posts: 1
 
Posted by: @skinnercz

Hi There, dont ask me why , but TRY to loose one of heatbed wheel rollers with hex-wrench.

I tried to fix some movement downthere, but it causes same problem. Now my bed is not like on rail, but there is some small movement(which did not affect print itself).May be it is too tight.

 

My problem was solved immediately.

 

Let me know ....

 

Only good prints 🙂

This is actually a very good point. As I have the same issue I was first trying to fix it the usual way recommended on other forums. Tighten belts, bed and all rollers to maintain the geometry of the printer. So actually I tightened excentric rollers on all axes.

After that, I found this forum and started to play around with the fan and overheating, but all my movable parts stayed too tight so motors had much more work to move it. I loosen it a bit to a normal state, opened the top cover, and put the new 80x80 fan underneath. Now I'm printing 14 hours bottom cover for 80x80 fan and it looks good so far.

The reseller contacted me after 2 days asking for video footage of the problem, but how do I do it when it will print correctly?   😉

This post was modified 1 year ago by gozo

ReplyQuote
seitretre
(@seitretre)
Eminent Member Registered
Joined: 1 year ago
Posts: 23
 

Hey there,

I have the impression that people here is repeating always the same. Furthermore, I have solved the layer shift issue, so I'm very grateful to @brodygoble for opening this thread and before to leave I want to leave to you all a summary of my experience.

I bought my Ender 3 V2 printer from Creality website just before Christmas. When I started to use it, I observed many layer shift and I discovered the root cause thanks to this thread.

Many printers bought at the end of 2020 are having some problems and printing with layer shift for jobs longer than 1 hour due to overheating of the 4.2.2 motherboard, that is the original board of the printer. It is possible to get some improvement opening the case and improving airflow, but it is not the solution.

The only ones that solved the problem, are the ones that replaced the 4.2.2 board wit a Creality 4.2.7 board for Ender 3 V2.

It's not easy to get the problem solved from Creality customer service, so some of us in the forum have bought it, it's cost is more or less 40€.

I have solved the problem insisting with Creality Customer Service, by email. Here what's happened.

  1. A first claim
  2. Creality offered me a new fan
  3. A second claim, saying we already know it's not the solution
  4. Creality said that the fan were out of stock and I had to wait
  5. A third claim, saying that 4.2.7 board is the solution and that I wanted a new board from them. I didn't care if it was a 4.2.2 board without problems or a 4.2.7
  6. They promised me to ship a 4.2.7 board
  7. They said me the 4.2.7 board were out of stock and I had to wait
  8. I decided to report their behavior to local authorities and told them that they may be charged a fine for not respecting what they say in their page in terms of customer experience (it's a scam) and for not respecting European laws. Moreover, I promised to share all this stuff in the social network. In the meanwhile, I had saved a copy of this forum in my PC
  9. Customer Service sent me a tracking code of a DHL shipment that arrived here in Spain in 4 days. It was a 4.2.7 board.

I have installed the 4.2.7 board and the printer is now working fine. No layer shift, good printings. I have spent one month struggling with Customer Service but they have solved the problem.

Conclusion:

  1. Choose another printer if you don't want to loose your time like I have done
  2. Choose Ender 3 V2 and buy a 4.2.7 board if you don't want to loose your time like I have done and you accept to spend your money for a faulty board.
  3. Choose Ender 3 V2 if you have time and will to insist with them to solve the problem you might have.
  4. Choose another printer if you want to avoid the risk to live all this nightmare.

It's time to leave for me, problem solved. Chapter ended.


ReplyQuote
traconn
(@traconn)
New Member Registered
Joined: 1 year ago
Posts: 1
 

Posting to confirm others findings:

I have a 4.2.2 board that I bought about a week ago at a Micro Center. Smaller prints were perfect while larger ones were having the same layer shifting problem.

I popped the top and bottom off the mainboard from my printer and propped them up and did a 4 hour print to see if that would help with any heating and 'popping noises'. That definitely worked! I attached a photo showing the differences, it's like night and day.

I think I'll be picking up an updated board later this week - clearly this is an issue.


ReplyQuote
Ivo-tje
(@ivo-tje)
Active Member Registered
Joined: 1 year ago
Posts: 10
 
Posted by: @kwilliams
Posted by: @gwnxander

I also buyed it with 123 3D but decided to cancel after the problems i thought that it only was a problem with the batch from 123 🙁

Same situation here, 123-3D.nl has been very open and helpful regarding the issue so kudos to them at least.

Hope a resolution comes soon otherwise I might have to look for an alternative printer.

Canceled the order today!

Let Creality fix it or at least send me the 4.2.7 board.

This post was modified 1 year ago by Ivo-tje

ReplyQuote
voltarwe
(@voltarwe)
Active Member Registered
Joined: 1 year ago
Posts: 6
 

@rob65 I can confirm that 123-3d , earn the kudo's!

3 or 4 weeks ago I send them a email about the Layer-shift. And they confirmed my email and also told that they ware aware of the problem. I also had contact in the beginnen of December, than i heard that sold A couple of the V2 ( more than a few 100). 

This Friday i received from them a new board( a,v4.2.7 and lots of tanks!). Sow there are lots of people who want a new board and i guess that they can only help a few of them.  

Sow, it will maybe take some time, but in the end they will solve the problem. cheers

 


ReplyQuote
shadycuz
(@shadycuz)
Active Member Registered
Joined: 2 years ago
Posts: 8
 
Posted by: @shadycuz

I'm on my third v2. This one seems to me okay and not affected yet. I'm on my third day of printing. It's still not that great of a printer. Even when you don't have layer shifting it kinda sucks compared to other printers. For example this "32bit" printer [can't print vase mode]( https://www.reddit.com/r/ender3/comments/j52rwy/ender_3_v2_stutters_in_vase_mode_which_worked/) over 25mm's second. Something even 8bit printers can do. I think everything about this printer is great but the control board. Just buy a [new one]( https://all3dp.com/2/3d-printer-controller-boards/).

Also I looked into this marlin bux fix branch and couldn't find anything that would fix our issues. I think the person who originally posted got confused when he seen our driver name in the commit log. You can find the PR [here]( https://github.com/MarlinFirmware/Marlin/pull/20731)

I just wanted to repost this for everyone coming in with this problem and wanting to buy a 4.2.7 board from creality. I personally think that would be a bad decision because overall these boards suck even when the layer shift is not happening. They have performance on par or worse than a older 8bit board. If you need a new board buy a nicer aftermarket board that is a drop in replacement. That is all <3


ReplyQuote
DavidMReynolds
(@davidmreynolds)
New Member Registered
Joined: 1 year ago
Posts: 2
 

Hey folks - forum freshman here just signed up to share my experience (cliff-notes in bold), and to say thanks for all the advice.

I purchased an Ender 3 v2 about 10 days ago, and had excellent results right out the box, barring a few plate adhesion issues. Long 30hr+ prints, no problem.

Then suddenly 72 hours ago, the machine developed a lound 'knocking' or 'thumping' sound, and I spotted some weird kicking from the extruder and some major (1-5mm) layer shifting.

After some mechanical checks, three failed large prints (4 hours each), and some extensive googling, I found this thread via Reddit.

By page 8 I was convinced - it was the overheading 4.2.2 board.

Not wanting to deal without a machine for an eternity, or to deal with Customer Services, I went ahead and purchased a 4.2.7 board on Amazon, £35 next day delivery.

Installed yesterday - and as if my magic, the problems have vanished.

It's hard to get excited about a machine going back to functioning as it did out of the box... but nice to have an easy solution, so thanks.

 


ReplyQuote
GwnXander
(@gwnxander)
New Member Registered
Joined: 1 year ago
Posts: 3
 

Customer service from creality3d is not responding to me so i think i need to order an new motherboard on my own costs.

I see the ender 3 and ender 3 pro version. Wich one do i need to take?

 


ReplyQuote
DavidMReynolds
(@davidmreynolds)
New Member Registered
Joined: 1 year ago
Posts: 2
 

@gwnxander all the same, just different firmware to flash on via SD card. Just don't get the ender 5 version.


ReplyQuote
rndwagner
(@rndwagner)
New Member Registered
Joined: 1 year ago
Posts: 1
 

you guys are awesome. I was pulling my hair out thinking it was an adhesion issue or a catch in one of the drive rollers or.... I was mid print and it had shifted twice already so i plugged in a small usb desk fan and I pointed it at the base near the board (air is blowing underneath printer) and holy crap no more shifts for the rest of that print. I had to scrap that one because of the shifts but i have since printed 3 more times (7 hours a piece) and not a single shift. I'll have to read over the thread again to see if anyone was successful in getting a new board from Creality? I've only had this printer for a few weeks.


ReplyQuote
ThePrimarch
(@theprimarch)
Active Member Registered
Joined: 1 year ago
Posts: 9
 

Hi All-

After reading through this thread, I contacted Creality customer support, and after providing photos and documentation I suggested that similar problems were solved by replacing the mainboard with version 4.2.7.  They agreed to ship me a new mainboard and fan in ~mid-January.

Yesterday (Feb 8) I received the new board (4.2.7) already configured / labeled for use in an Ender3 V2, but not a new fan.  I installed the mainboard, and it worked immediately, with no need for a bios flash.

After a short test print I started a ~12-hr print with the mainboard in a fully closed up mainboard enclosure (as it is originally packaged).  No layer shifts at all.  I will update if layer shifts reappear in later prints.


ReplyQuote
Pim
 Pim
(@pim)
Active Member Registered
Joined: 1 year ago
Posts: 5
 
Posted by: @pim
Posted by: @rob65

I just received an email from a friend telling that our local distributor (123-3D.nl) just received a new batch of v2 units. They did an in-house test and discovered that these new printers still have this problem. They are now in contact with Creality to identify a solution.

I'm getting curious as to what has changed since November.

Can it be that hard to identify, and fix, the problem or is Creality just stubborn ?

I ordered the v2 three days ago and received a message from 123-3.nl that they experienced these problems and therefore did not sent the printer. I have the options of:
1) Getting the printer
2) Wait until the problem is fixed
3) Get an Ender 3 pro, with upgraded glass print plate, some spray and filament
4) Get my order canceled and receive a refund.

There is no mention of an option for the updated 4.2.7 board that has been mentioned in other posts. As this is going to be my first printer I'm now doubting about what to do.

Get the printer, try and get the updated motherboard, as people are commenting positive experiences. 
Or, look at another printer, but trying to to exceed the initial budget?

So, here's what I ended up doing.
I decided not to go with the v2. I Ordered a 3 Pro from Creality, as the ones here in my country were sold out, or more expensive then they should be.
Also decided to upgrade the hell out of the thing with the price difference compared to the v2.
Ordered an SKR mini board to replace the one in the pro and some other things like extruder, Capricorn tubes. Upgrades like a different hot-end and other nozzles might be added in the future. Thought about an auto-bed level, but a similar feature resides in the SKR mini's firmware.

Had thoughts about a CR-20 v2, but there wasn't as much support/community around that model.

With the pro there are enough mods around to upgrade the printer itself to help get started with projects and get familiar with things.
Thanks for peoples offered insights, and so I'm offering mine.


ReplyQuote
3nderUser
(@3nderuser)
Estimable Member Registered
Joined: 1 year ago
Posts: 114
 

Me happy too  ? ?  I think.
Received a brand new board from Creality Customer Service today.
It's version 4.2.2 for Ender-3V2, same as original came with printer.
So let's hope it doesn't have this fault in it.


ReplyQuote
griffincorriher
(@griffincorriher)
New Member Registered
Joined: 1 year ago
Posts: 2
 

Glad I found this thread before I wasted more filament trouble shooting layer shifts. Ended up purchasing a 4.2.7 board from Amazon to replace mine after the Amazon reseller wanted me to test resistance and voltage on motors and the board.  I told them I wouldn't do that and would instead install my own board. Today they offered to refund me the cost of the 4.2.7 board, so hopefully they follow through.

Edit: the refund came through.

 

This post was modified 1 year ago by griffincorriher

ReplyQuote
hantuuk
(@hantuuk)
Eminent Member Registered
Joined: 1 year ago
Posts: 40
 

I thought I'd chime in about this layer shift problem. 

I bought an Ender 5 Pro two weeks ago with a 1.1.5 board. I am also experiencing the same problem. Small calibration prints are fine, but anything prints with bases more that 50 by 50mm the prints starts shifting only on the y-axis. I don't get any thumping noises though.

Maybe I should have waited as I heard the latest Ender 5 Pro comes with a 4.2.7 boards.

I tried to contact Creality but they are on their Chinese New year holidays. I have contacted my seller and told them about my problems. They have not got to the bottom of it yet. So I guess its not just the 4.2.2 board, the fault was in the earlier 8 bit boards as well. Just wondered if its both a firmware and hardware problem. I am thinking of replacing the board to a 4.2.7 board which I would need to set it up with an Ender 5 Pro firmware.

By the way, so far I haven't seen this issue reported here in the Ender 5/Pro threads.

Thanks

Creality Ender 5 Pro


ReplyQuote
Page 16 / 25