Forum

 

Notifications
Clear all

Firmware update fails - beeping display


mgrobot
(@mgrobot)
New Member Registered
Joined: 1 year ago
Posts: 1
Topic starter  

Hi!

I want to install a Bltouch module because my print bed is warped heavily. Can't level it with the knobs.

I have a 4.2.2 board and downloaded the corresponding bltouch firmware from crealitys download page (with bltouch support), I even tried the original marlin builds with the same result.
As soon as I update the firmware on the printer by inserting the sd-card and booting it up, the screen stays black (only backlight turns on) and the display starts to beep like crazy.

Any suggestions what to try next?


ReplyQuote
Wurlitzerwilly
(@wurlitzerwilly)
Eminent Member Registered
Joined: 1 year ago
Posts: 42
 

Firstly ensure that you use a good quality uSD card, NOT the stock one.
The SD card must be no bigger than 32GB.
Ensure it's formatted FAT32 then put the firmware .bin file in the root.
The firmware filename must be unique (not used previously) and must be no more than 23 characters long including the .bin extension. I use "firmware<date><time>" for uniqueness.
I suggest that you use the firmware from Smith3D, not the Creality one.
The Smith3D has some nice extras - just make sure you download the default one for the 4.2.2 board. You can always change it later.

https://smith3d.com/category/firmware-guides/


ReplyQuote
alanerickson
(@alanerickson)
Active Member Registered
Joined: 1 year ago
Posts: 12
 

@mgrobot  I had the same problem.  Figured out that I was using the wrong build with my Ender 3 V2 with a 4.2.2 board.   Should have been using the V2 build and not the Ender 3 4.2.2 board build.


ReplyQuote
hobbitfeet
(@hobbitfeet)
New Member Registered
Joined: 2 months ago
Posts: 0
 

I tried updating for the BL touch.  The first few times I tried booting it up, I just got a blank screen.  After trying a few things, I have a blank screen and a horrible beeping noise.


ReplyQuote
rygle
(@rygle)
New Member Registered
Joined: 2 months ago
Posts: 1
 

@hobbitfeet The Beeping probably means you are using the wrong version of firmware. I had this problem when I downloaded and installed an Ender3 firmware instead of an Ender3V2 on my printer.


ReplyQuote
craigchilds
(@craigchilds)
Active Member Registered
Joined: 2 months ago
Posts: 5
 

I had the same issue, I resolved it by spending an hour or so learning to compile Marlin and used the latest version, it was the best option for me but it does require a bit of technical knowledge so it's not for everyone.


ReplyQuote