Forum

 

Notifications
Clear all

Bltouch not working after install.


Valenhart
(@valenhart)
New Member Registered
Joined: 9 months ago
Posts: 3
Topic starter  

Greetings all.

I just wired up a BLtouch that I received directly from Creality, disabled the z endstop  and updated to the latest firmware. 

The Bltouch cycles twice, then stays lit red. The printer does not function anymore at that point and will not move. I revert back to the initial firmware and disconnect the bltouch and the printer works again. I have tried several times, and even traced the connections to make sure they matched and still nothing.

Thoughs?

 


ReplyQuote
Wurlitzerwilly
(@wurlitzerwilly)
Eminent Member Registered
Joined: 9 months ago
Posts: 42
 

@valenhart
You don't say which printer model you have.
Take a look at the Smith3D firmware page. It shows correct connections and their firmware (IMO) is the best for the job.

https://smith3d.com/category/firmware-guides/


ReplyQuote
Valenhart
(@valenhart)
New Member Registered
Joined: 9 months ago
Posts: 3
Topic starter  

It's an Ender 3 V2.


ReplyQuote
spacelab
(@spacelab)
New Member Registered
Joined: 9 months ago
Posts: 2
 

@valenhart did you flash the correct firmware? Do you have a 4.2.2 or 4.2.7 board?


ReplyQuote
Valenhart
(@valenhart)
New Member Registered
Joined: 9 months ago
Posts: 3
Topic starter  

@spacelab You nailed it. it was a 4.2.2 and I was flashing the 4.2.7. Seems to be functioning now. Thanks all for the help.


ReplyQuote