Forum

 

Z axis not lowering...
 
Notifications
Clear all

Z axis not lowering after BL touch installation

Page 2 / 2

ramcneal
(@ramcneal)
New Member Registered
Joined: 12 months ago
Posts: 2
 

I've got the same problem unfortunately. My motherboard is 4.2.2 and I installed the firmware. Auto home is stuck on the z-axis homing. After power on I do see the BLtouch go in and out twice, but now the z-axis just doesn't work. I used the motion control for the z-axis and the arm fails to move at all. I guess I'll try installing the base level firmware and the old z-axis switch in the hopes of getting the machine back to it's original condition.


ReplyQuote
ramcneal
(@ramcneal)
New Member Registered
Joined: 12 months ago
Posts: 2
 

Figured out my problem. Like someone suggested I reinstalled the base firmware and reinstalled the z-axis switch. I verified that my z-axis movement worked again. I then followed the instructions very carefully and here's what I believe is key. Install the correct version of the firmware, turn the machine on and update the firmware with the old z-axis switch still in place. Then install the BLTouch and power on the machine. While previously I did update the firmware at first, but then I had installed the wrong version of the firmware for my board. I installed 4.2.7 firmware and I've got 4.2.2. So, after my machine was running 4.2.7 with the BLTouch installed I updated the firmware again with 4.2.2. That seems to be the trouble. So, when I went back to the base with the old switch and following the steps again everything works. I hope this helps someone else.


ReplyQuote
inamahamed
(@inamahamed)
New Member Registered
Joined: 11 months ago
Posts: 1
 

@johnharrington Blow up mean what ?? Why confusing people ? can u put a bL touch connector jack to another port or can you attach BL touch connector wrong way ? will it go inside ??


ReplyQuote
NV1976
(@nv1976)
New Member Registered
Joined: 11 months ago
Posts: 1
 

@philiphoward A million thanks headed your way.

The above solution was the perfectly prescribed salve for all my frustrations when it came to my Z offset.

 


ReplyQuote
bit.factory
(@bit-factory)
New Member Registered
Joined: 10 months ago
Posts: 1
 

for 4.2.7 if you want to use all the 5 pin of bl-touch plug:

in Configuration.h, you have to

comment:

//#define USE_ZMIN_PLUG
and 
//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN
 
uncomment:
#define USE_PROBE_FOR_Z_HOMING
 
leave commented:
//#define Z_MIN_PROBE_PIN 32
alternatively
 
you must use 3 pin of bl-touch plug and two of z- plug for black/white wire with black on the left side (reading label). This second solution commits Z- pin you should use for other purposes (i.e. filament runout)
 
Both solves for me. I prefer naturally the first one.
 

 


NeiKKeD liked
ReplyQuote
shotah
(@shotah)
New Member Registered
Joined: 9 months ago
Posts: 0
 

@philiphoward Delete the eprom data on your SDisk. I noticed my printer acting similar to yours but was being normal with the Upgrade SDisk in it. Example the auto leveling took the 9 samples it was supposed to, and the auto home sat where it was supposed too. 

Hopefully that helps, everything else made a lot more sense when everything started working properly. 


ReplyQuote
Bbeettaa
(@bbeettaa)
New Member Registered
Joined: 8 months ago
Posts: 1
 

Hi All,

 

I also have this same issue, Z axis not lowering and stuck on screens says Autohoming. 

My BL touch is what I believe to be the smart version, with the adapter for the motherboard (2 pin black and white, 3 pin red, blue, yellow).

 

I have checked the firmware, all appears fine. Could someone link me to the firmware for a 4.2.2 board Ender 3v2 please? 

I have seen a video suggesting rewiring of the 3 pin connection, something to do with the ordering. Did anyone do this? 

 

Thanks


ReplyQuote
PerF
 PerF
(@perf)
New Member Registered
Joined: 8 months ago
Posts: 1
 

@bbeettaa i was also struggling with the Auto home (i have a Ender 5 Pro, 4.2.2 board), but found out i needed the firmware for BL touch called "Marlin2.0.1-V1.3.1-BLTouch (with adapter board)" after installing this all worked perfect.


ReplyQuote
jester
(@jester)
New Member Registered
Joined: 7 months ago
Posts: 1
 

@tpratt83687 i have the same exact issue with my ender 3 2020 updated version the 4.2.7 malvin software doesn't work at all and I've flashed back and forth on the software and hasn't resolved my issue but my light doesn't come on either on my bl touch i believe i had it on before but according to the instructions and a couple videos i had to swap a couple wires in the connectors i may try switching them back when i can get back to my printer but asides from that I'm at a loss im very new to 3d printing and the computer skills needed for alot of it 


ReplyQuote
NeiKKeD
(@neikked)
New Member Registered
Joined: 5 months ago
Posts: 1
 

@bit-factory you absolute legend, I registered for an account just to say thank you! So far, no problems at all! BLT deploys, stows, homes and levels perfectly! Once again many thanks!


ReplyQuote
dynodon
(@dynodon)
New Member Registered
Joined: 1 year ago
Posts: 2
 

After installation of the BLTouch device ….

I have been unsuccessful getting my  printer to achieve the proper Z height (it always seeks to 10mm, or more,  above the bed).

  • When I turn on the ENDER-3 the BLTouch lights up RED and goes: up/dn, up/dn, up then remains up and solid red.

 

  • After Home command, X and Y are correct; Z is either 10mm (in the air) or gains additional height above 10mm.

 

  • Zstop plug didn’t need it so I unplugged and left it hanging

 

  • After homing and determining my setup is as instructed, I tried setting the Z offset on the printer menu.  It only goes to -9.9 mm and obviously, this is way too little.

 

 

Printer:

Without the BLTouch the printer previously has successfully has printed multiple items.

Ender-3 (pro V1.5 as reported by Marlin) with 4.2.2 control board, 32 bit processor

BLTouch connected to the boards 5 wire interface connector.

Marlin    bugfix.2.0.X (marlin.crc.id.au)

 

Requesting some guidance, please.


ReplyQuote
Page 2 / 2