Forum

 

Z axis not lowering...
 
Notifications
Clear all

Z axis not lowering after BL touch installation

Page 1 / 2

sr6767
(@sr6767)
New Member Registered
Joined: 10 months ago
Posts: 4
Topic starter  

Hi, new member here and a bit stuck after upgrading my ender 3 pro to a 32bit board (v 4.2.7) and adding the bl touch.

I've flashed the firmware (4.2.7 Ender-3 pro 32bit Marlin2.0.1 BLtouch V1.3.1with adapter board TMC2225.rar) and all seems to be ok however when I try to auto home the z axis will not lower and I get a stopped message on screen.

I've included a small clip of what its doing.

Hope someone can point me in the right direction and thanks in advance.

 


ReplyQuote
tpratt83687
(@tpratt83687)
Active Member Registered
Joined: 11 months ago
Posts: 12
 

@sr6767 Looks like something went wrong with the firmware upgrade. I would unplug the small plug on the side of the BLTouch and try flashing with the bare-bones 4.2.7 firmware verify that everything is working properly. If all goes well, rename the BLTouch version and try flashing again. 


ReplyQuote
sr6767
(@sr6767)
New Member Registered
Joined: 10 months ago
Posts: 4
Topic starter  

@tpratt83687 thanks for your reply 

so I disconnect this and flash using the firmware which doesn't include the BL touch? sorry I'm new to this!

 


ReplyQuote
tpratt83687
(@tpratt83687)
Active Member Registered
Joined: 11 months ago
Posts: 12
 

You're on the right path!  Try this link to a GoogleDrive that has some Marlin firmware for Ender 3 Pro with 4.2.7 bot with and without BLTouch.  Hope this works for you.  Don't forget to slightly change the filename after putting it on an 8GB or 16GB SD card formatted to FAT32.  I usually just add a "a" to the end of the filename (like firmwarea.bin or something like that).

 

https://drive.google.com/file/d/1kH1ljOM6WpiuON7AYkVNaXFSkTcUVgDF/view?usp=sharing


sr6767 liked
ReplyQuote
sr6767
(@sr6767)
New Member Registered
Joined: 10 months ago
Posts: 4
Topic starter  

@tpratt83687 you were right about the firmware, Id used the firmware without the adapter board when I needed to use the one with the adapter. Now the z axis is working but it wont stop as I auto home, it just keeps going!


ReplyQuote
tpratt83687
(@tpratt83687)
Active Member Registered
Joined: 11 months ago
Posts: 12
 

By "just keeps going" do you mean it's crashing into the bed?


ReplyQuote
sr6767
(@sr6767)
New Member Registered
Joined: 10 months ago
Posts: 4
Topic starter  

@tpratt83687
yes I did..
The black and white wires were the wrong way around so I've sorted the issue of the z axis moving down. Now I'm getting a err too far message as when it auto homes it stops about 20mm away from the bed. So frustrating!


ReplyQuote
Teeg
 Teeg
(@teeg)
New Member Registered
Joined: 9 months ago
Posts: 1
 

@sr6767 Did you ever figure the auto home issue? I'm having a similar one with my Ender 3v2 after just installing the BLTouch this morning.


ReplyQuote
Scrapmetal52
(@scrapmetal52)
New Member Registered
Joined: 9 months ago
Posts: 4
 

Has this issue ever been solved?  I have almost the same issue with my Ender 3 Pro.  I have the BLTouch installed on a 4.2.7 mainboard with the adapter.  Downloaded the firmware from Creality site that is supposed to be for the 4.2.7 board with a BLTouch hooked up using the adapter board. When I tell it to Auto Home it does the X & Y OK then for the Z the probe deploys a couple of times but then the Z-axis goes up and it just stops with the nozzle about 20mm above the center of the bed.   Can't seem to set any home offsets because I get the error message "Too far".

 


ReplyQuote
Philiphoward
(@philiphoward)
New Member Registered
Joined: 7 months ago
Posts: 1
 

So I had similar problems. BUT I THINK I FIGURED IT OUT

 

Ender 3 Pro with 4.2.7 Creality silent board and Creality official BL touch with SINGLE CABLE CONNECTION to motherboard.  Also, this was a mistake and I should have done this first and run a few prints to dial it in before doing the BL touch, but I installed the Creality yellow bed leveling springs because I thought more tension on a screw would keep it from spinning in the socket instead of tightening like its supposed to (spoiler: it didnt) 

SO.....Start with a manually leveled bed.  Just do it.  Print a few things to make sure before doing any work.  Trust me.  It will likely save you steps.  

This was a challenge to me because it obvious as to where this plug goes on the motherboard.  Its a single connection.  However, there are few to no videos on plugging it in.  (more on this in a second)

So here we are, everything connected.  Firmware from Creality website flashed (Ender-3 Pro_4.2.7_BLTouch_Marlin2.0.1_V1.1.2_TMC2225.bin).

 

Turn it on.  Select "home"

Head moves to original X/Y, 0/0 axis and then proceeds to move to the center(ish) of the bed with the probe.  Then deploys the bin on the BL touch, lowers to touch the bed until the pin registers, and repeats the process a second time and moves back up and stops even higher.  I measured the height at approximately 13mm off the bed.  This is completely different than the behavior of the previous firmware where the head stopped at 0/0 to await the next command.  This doesn't seem right at all (more on this too)

Back to the web.  Apparently there ARE cables like mine and a few have them and its plugged in correctly.  (After determining maybe I need the Zstop plug in place and then figured out  I definitely didnt need it so I unplugged it again and left it hanging)

After homing and determining my setup is as instructed, I tried setting the Z offset on the printer menu.  It only goes to -9.9 mm and obviously, this is way to little to make up for that 13 mm gap.  This just wont work.  But then a light came on..... why not try printing, as stupid as it sounds, and see what happens.

 

SO here is my current fix:

This was a challenge but I got it to successfully print a few test prints after some minor damage to the magnetic surface and heres how:

1) After homing, disable stepper motors and level bed as you would with a piece of paper in all 4 corners.

2) preheat bed/end to prepare for print.

3) Start printing your test print.  Ideally one of those with thin layers in the corners with a center spot and a skirt all around the bed.  This will help you dial it in further and waste little filament as well as really dial in each segment of the bed.

4) before my test print, Im using one I sliced without adding the G29 code to the slicer settings (super easy to do by the way and no compiling any data for a new firmware), the head goes to the center(ish) again and deploys the probe a few times and then drops close to the bed and starts printing.

5)While is starts printing, I go into the menu Control > Bed Leveling > Probe Z offset and I start turning the knob to the left to go to negative values and bring the head closer to the bed.  I wind up around -3.4 mm (You will need to find your own ideal value as Ive seen lots of ranges on the web.  Im using the Creality included mount for this so one would think its fairly uniform but apparently not) and when the squish seems like its getting there, scroll further down in the same Bed Leveling menu and click "save settings".  It will beep to confirm.

6)Last step *phew*.  Now its time to really dial in the bed by using the knobs.  I adjusted each one during the print to get that squish ideal.  Too close, it leaves ridges.  Too far, it looks stringy.  This was a serious challenge due to my spinning screw in the back corner that requires effort to hold as well as tighten at the same time (for me at least.  I sould probably reach out to Creality and see if there is a fix without tearing off the magnetic adhesion because I really like that part).  I went through about 5 test prints to really dial it in and it likely will need a few more to get it perfect.  But that should do it.

 

IN CONCLUSION:  I think the "floating center head" is the correct initial behavior with a new "home" but am still very confused by all the effort I put in manually leveling the bed if the BL touch is supposed to correct for this.  Being new, I have yet to figure this part out, but at the very least, I have a working printer that is able to make successful test prints until then.  I hope this all helps everyone with the issues and frustration.

 

Now:  Hey Pros.  If anyone read this far......How'd I do?  Any further advice?  Did this help anyone?

Please let me know!


NV1976 and CYT liked
ReplyQuote
johnharrington
(@johnharrington)
New Member Registered
Joined: 5 months ago
Posts: 1
 

@sr6767

 

I solved this. If you're using stock firmware, make sure you're  using the dedicated 5 pin BlTouch port near the screen cable. If you use a pin27 board or use the endstop switch port, your printer will act like there's  no z stop, as a safety measure. Make sure you have a proper 5pin creality connector on one end, or wire your connector accordingly. WARNING: IT IS EXTREMELY EASY TO BLOW UP YOUR BOARD WHEN DOING CUSTOM WIRING. BE CAREFUL.


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 8 months ago
Posts: 1045
 

@johnharrington Good point!


ReplyQuote
CrimsonDragon38
(@crimsondragon38)
Active Member Registered
Joined: 5 months ago
Posts: 14
 

I am having the same issue and have tried all of these steps still with no luck. Someone please help.

Edit: Something I did fixed the issue.


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 8 months ago
Posts: 1045
 

@crimsondragon38 How? Or you do not know as well? ? 


ReplyQuote
CrimsonDragon38
(@crimsondragon38)
Active Member Registered
Joined: 5 months ago
Posts: 14
 

@kevin It was a mistake, flashed firmware without bltouch. allowed z-axis to move properly but without z-stop sensor it hit the build plate. was not an actual fix.


ReplyQuote
Page 1 / 2