Ender 3 v2 firmware...
 
Notifications
Clear all

Ender 3 v2 firmware to support BL touch and Smart filament sensor


han
 han
(@han)
Screw Registered
Joined: 3 months ago
Posts: 1
Topic starter  

I have recently bought an Ender 3 v2 printer, BL touch v3.1 and a Smart Filament sensor. Creality have kindly provided a Firmware that support the BL touch but not the Smart filament sensor by bigtreetech.

I tried updating the firmware using the Creality source code to support both bl touch and the filament sensor but i get a blank screen on the printer LCD. I also tried the latest Marlin 2.7.0 and / or the Bugfix 2.0x firmware this resulted in other multiple issues.

  • For the Bl touch, the levelling doesn't working and the nozzle just goes to the middle and doesn't do a 3 by 3 check. I rest the firmware on the printer which resulted in the nozzle just diving straight into the hotbed. 
  • Another issue i am getting is regarding the Smart Filament sensor. When i was testing the firmware, i cut the filament and its stops  the print (yay) but, when i stop the print straight after it freezes the printer and nothing works other then the main kill switch.

I have been wrecking by brain for the past week now and I can not seem to get it to work. Can someone help me as i am not got with the coding side of firmware. i have attached the BIN file below.


ReplyQuote
Justin Schubert
(@justin-schubert)
Heating Block Registered
Joined: 5 months ago
Posts: 14
 

never use bugfix they have not got it running yet use Visual basic and platform IO to make a Bin file  or Hex   yourself set Default Environment in platformIO.init to STM32F103RET6_creality do a build... FIRST MAKE A FILE with MARLIN 2.x.x ONLY NO Custom settings and see if it builds of so Modify that file. or use the one I got off if Github...

Remember to format your SD saving your factory stuff first then put only the bin File in the SD power off the Ender3 Pro and Unplug the USB then Insert the SD card with the Firmware on it and turn on the power switch it will take a few seconds  for the new update to install... then do a Home with your finger on the power switch... then check if it will allow Filament change too Turn it off if it dose not work and try again... this is how I learned...MVB


ReplyQuote
Scroll Up