Forum

 

Ender 3 Pro w/ 4.2....
 
Notifications
Clear all

Ender 3 Pro w/ 4.2.2 using BLTouch 3.1 - Can't get past Step 1 of bed leveling


devolutionist
(@devolutionist)
New Member Registered
Joined: 7 months ago
Posts: 2
Topic starter  

Printer is an Ender 3 Pro with 4.2.2 board, BLTouch is a new v3.1 with the single connector that runs to the port on the 4.2.2. 

Basically, I can't seem to get through the BLTouch initial leveling process.

Everything until now was really straightforward. 

- I updated the firmware which was downloaded from Crealty.  This firmware was posted on 16 Jan 2021.  Iin the downloaded zip file I went to the folder "Marlin2.0.1 BLtouch V1.1.2 without transfer board" and used the file "Ender-3 Pro- Marlin2.0.1 - V1.1.2 - BLTouch.bin".

- I connected the BLTouch 3.1 to my 4.2.2 board using the 5-cable connector provided and removed the z-stop switch

- I ran Auto Home and adjusted z-offset to -2.0 after doing a clearance test with A4 paper, and saved the settings

- I ran Auto Home again, which works fine using the BLTouch.  This should confirm that the BLTouch is working and wired correctly.

However, when I run Control > Bed Leveling > Level Bed (to run the 9-step leveling process) it goes to position 1, BLTouch deploys the probe, and then instead of moving down and touching the bed it moves up about 5mm, pauses, moves up about 5mm again and then stops - with BLTouch still reset (blue) and ready to measure.

Things I've tried:

- Re-flashing firmware

- Made sure bed is already roughly level by having the bed bolts screwed into the height wheels the same number of rotations. Currently the bed is up pretty high with only a couple of turns available on the wheels before they come off the bolts. The bolt end currently is flush with the bottom of the wheel.

- Restoring failsafe settings on the printer and tried starting over

- About 3 times during my iterations I've got the 9-step process to finish, but the nozzle was always way too high for a print. I don't think I have gotten the 9-step leveling process to finish after setting the calibrated z-offset.

- After applying the failsafe settings, removing SD card, running auto-home, and then bed leveling, it'll go to position 1, and then start moving down like it's actually going to touch the bed and do a measurement, but then just stops short without touching.

- I've checked cabling between the BLTouch and the 4.2.2 board and it all appears to be correct with no connections crossed.

 

Any ideas?


ReplyQuote
devolutionist
(@devolutionist)
New Member Registered
Joined: 7 months ago
Posts: 2
Topic starter  
Progress here - got some advice on how to incorporate manual bed adjustments into the setup process. Here's the process:
 
  1. Run Auto Home
  2. Select prepare > move axis > z and dialed it to zero
  3. Put paper under nozzle and go to Prepare > Z Offset and move it down in 1.0 increments until it touches.
  4. Fine tune Z offset (although mine won't do 0.x increments)
  5. Disable Steppers
  6. Paper level the four corners like you would normally
  7. Run Auto Home again
  8. Fine tune Z offset more to ensure paper test is correct at center
  9. Select Control > Leveling > Bed Level and it'll run through the 9-step test
  10. Print a test bed pattern and observe the nozzle height to make sure it's correct
  11. If yes, done, if not, fine tune Z offset more.
So now I'm close and get through the 9-step leveling process, but when I print my nozzle is still way too high and it just drags filament around. So my z-offset still needs tweaking - but the controls in this version of the firmware don't seem to allow adjustments there smaller than 1mm, so I've got to either guess at my correct offset or... something else.
 
Root cause: The instructions that came with the BLTouch were woefully inadequate.
 

ReplyQuote
dynodon
(@dynodon)
New Member Registered
Joined: 3 months ago
Posts: 1
 

Hello,

I have an Ender 3 with the stock 4.2.2 board in it. I just picked up a genuine BL Touch 3.1 kit and installed it. I updated the firmware for the V4.2.2, Ender-3  32bit Mainboard with Marlin 1.3.1 supporting BLTouch. The printer seemed to be fine. However I cannot manage to set the Z Axis. When I hit auto home it goes to the middle of the build plate and increments Z, 5 or 10, also the sensor begins to blink. I ran through figuring out the offset number but the instructions say to look at Control >Motion Z Axis and I don't have that. The directions that came with the kit were not as helpful as needed for this part. I would appreciate any help.

The Z-axis will not move downwards, when I try to level the bed it says I need to home the Z-axis and when I try to home the axis it produces the message “Stopped” !

I tried to gently pull down the touch tip before doing the HOME command. The BL sensor  does not blink continually as before but the system still has a Z axis of 10+ which can’t be changed. Pressing HOME again produces the same behavior and 10+ Z axis.


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@dynodon I suggest you contact the merchant and get a new one. Your device is moving without a clue.


ReplyQuote