Ender 3 Pro v4.2.2 ...
 
Notifications
Clear all

Ender 3 Pro v4.2.2 board bltouch kit


chrisarchon
(@chrisarchon)
Active Member Registered
Joined: 4 months ago
Posts: 5
Topic starter  

Hello.

 

I have an Ender 3 Pro with a v4.2.2 board (32bit).

I ordered the one that says "ender 3 pro/ender 5 pro/cr10" .

Is this one intended for my printer or is it for the ones that come with an 8bit board ?

I ask because a friend of mine has an ender 5 pro with 4.2.2 board and he also ordered this one and he had issues connecting it.

He couldn't connect it without the adapter (as I remember 4.2.2 are supposed to have a dedicated connector for bltouch and not need the adapter).

Also the cabling was wrong. He had to switch vcc with ground.

Has creality made a mistake and for latest ender 3s and ender 5s that come with 32bit boards this isn't the correct bltouch kit to order ?

Maybe everyone that has a 32board should get the one for the "ender V2" which comes only with a 32bit board?

 

Can anyone please shed some light?

I have send a question to support, I hope they see the email before they ship it.

If not I hope I ordered the correct one.

 

This topic was modified 4 months ago by chrisarchon

ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@chrisarchon The BLT kits you order for "ender 3 pro/ender 5 pro/cr10" should have an adapter as the picture showed, right? So that should be a 3+2 pin type of wire connection. But there is a 5 pins slot for the BLT wire connecter on your v4.2.2 board (32bit).
So you will have two different ways to connect the cable and the corresponding firmware_with OR without an adapter. Be careful with it!
I think it is not a mistake, as although the latest Ender-3 pro and 5pro have a V4 mainboard but there are many old version printers that have a V1 board. They just did not make it clear enough. I think they should fix this situation.


ReplyQuote
chrisarchon
(@chrisarchon)
Active Member Registered
Joined: 4 months ago
Posts: 5
Topic starter  

@kevin

So if i understand correct, for V4 boards the optimal kit is the one for the V2.

But the old kit will still work.

Correct?

 

By mistake I mean that they should update the description to write that if you have an ender 3 / ender 5 with V4 board you should order the updated version.

This post was modified 4 months ago 2 times by chrisarchon

ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@chrisarchon Correct! The key-problem is the method of wire connection, not the version of BLT kits. Unfortunately, many users have no idea about printers' mainboard version. Maybe that is why they classify according to the machine type.


ReplyQuote
chrisarchon
(@chrisarchon)
Active Member Registered
Joined: 4 months ago
Posts: 5
Topic starter  

@kevin

Thank you very much for the information.

I got an email from creality that my order is shipped already so it seems they didn't read my email so I could change my order 🙁

Can I buy the cable that connects the bltouch, with the dedicated connector that v4 boards have, separately ?


ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@chrisarchon I did not try that, but I think it is totally ok.


ReplyQuote