Forum

 

Ender 3 pro 4.2.7 b...
 
Notifications
Clear all

Ender 3 pro 4.2.7 board firmware issues.


Twml
 Twml
(@twml)
Active Member Registered
Joined: 6 months ago
Posts: 11
Topic starter  

I have a ender 3 pro and i installed a 4.2.7 board. i wanted to enable filament runout. so i downloaded marlin from github and used the creality E3Pro example configs. changed the defines required to enable filament runout and compiled. after flashing it appears fine.

 

when heating the hotend it is ok, when heating the bed as it heats the screen constantly "clicks" like the button was pressed and the beeper makes the click sound, making the lcd and controls useless any time the bed is heating, it did add filament runout support though as the option is now im the settings and listed as: On... but i cant use printer with the clicking screen. any advice?

 

i dont have a bltouch so i cant use stock official firmwares as they are bltouch+filament runout and cause my beeper to constantly churp/chatter the whole time printer is on. 

 

 

Im using stock marlin MarlinFirmware/Marlin 2.0.x from github, and the example configs for ender 3 pro in MarlinFirmware/Configurations for 2.0.x. made the changes to enable filament runout in this guide.

https://all3dp.com/2/ender-3-filament-sensor-runout/  

This topic was modified 6 months ago by Twml

ReplyQuote
3nderUser
(@3nderuser)
Estimable Member Registered
Joined: 9 months ago
Posts: 114
 

Did you open this issue on github?? There is also issue with filament runout sensor in latest version when checking list of issues.

https://github.com/MarlinFirmware/Marlin/issues/21408

Else try previous version of Marlin.


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@twml   Is the filament runout sensor from Creality? If yes, try this one.


ReplyQuote
Twml
 Twml
(@twml)
Active Member Registered
Joined: 6 months ago
Posts: 11
Topic starter  

@3nderuser

i did open an bug report havnt heard anything back other then try 2.0.x bugfix and it still has the issue there too. 

 

@kevin

thanks ill try that firmware and report back, i didnt see a creality firmware on their website for E3Pro with just filament runout enabled, they were stock / bltouch / bltouch addon board... and i dont have a bl touch so it caused buzzer to constantly chatter. 


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@twml I got this from Creality Tech Team, Hope it works!


ReplyQuote
Twml
 Twml
(@twml)
Active Member Registered
Joined: 6 months ago
Posts: 11
Topic starter  

@kevin nope doesnt work, flashed ok, no option in settings anywhere for filament runout. when clicking the sensor the printer shows the ender logo splash screen, the heating stop sets them both to 0 and makes the extruder motor twitch a bit each time the sensor is loaded/unloaded. no error messages no filament change notice. 

my sensor is creality 3 wire switch connected to the filament sensor port on the 4.2.7 board not a pin 27 board on screen ribbon.

 

thanks for trying though. odd it doesnt work for me if printer is the same. idk.

This post was modified 6 months ago 2 times by Twml

ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 7 months ago
Posts: 1045
 

@twml If you never mind, shot a video about how the screen shows when clicking the sensor. I can have some discussion with the Creality team. Thanks.


ReplyQuote
Twml
 Twml
(@twml)
Active Member Registered
Joined: 6 months ago
Posts: 11
Topic starter  

Got it working with the firmware you provided @kevin thank you very much.

my sensor it had a broken wire in the cable for the middle ground wire causing signal issues

and firmware to crash then reboot.

 

until official marlin fixes the bug iv been having with the screen clicking this firmware is perfect. 

 

woohoo!


ReplyQuote