Forum

 

Ender 3 Pro 4.2.2 w...
 
Notifications
Clear all

Ender 3 Pro 4.2.2 with BLTouch V3.1 Hardware or Firmware problems


amcneish
(@amcneish)
New Member Registered
Joined: 11 months ago
Posts: 2
Topic starter  

I have added a BLTouch V3.1 to my Ender 3 Pro 4.2.2 and I have loaded the firmware version V4.2.2-Ender-3 Pro-32bit Mainboard-Marlin2.0.1-V1.3.1- BLTouch.bin but I don't get a progress bar when loading and the LCD screen is lit up as all over blue with no graphics. The BL touch is flashing red about once per second. After turning off and removing the SD card when I turn it on again the BLTouch does one probe extension and then continues to flash about once per second. The LCD screen has no text or graphics and is lit all over in blue. Hardware or Firmware or Both???


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 1 year ago
Posts: 1045
 

@amcneish It is hard to say now, you can try to take the BL-touch off and reflash the original firmware if the printer can work correctly, then you can determine that it is the firmware issue.


ReplyQuote
amcneish
(@amcneish)
New Member Registered
Joined: 11 months ago
Posts: 2
Topic starter  

@kevin I think I have diagnosed the problem to the pinboard that connects the video cable and the BLtouch sensor. It seems to have an intermittent connection. If I push it together it seems to work but of course I can't do that all the time. I'm trying to figure out a way of clamping it to the motherboard.


ReplyQuote
kevin
(@kevin)
Noble Member Registered
Joined: 1 year ago
Posts: 1045
 

@amcneish Do you have a hot melt gun? You can push them hard and then use a melt gun to secure them together.


ReplyQuote