Bltouch firmware up...
 
Notifications
Clear all

Bltouch firmware upgrade not loading

Page 1 / 2

Graham35p
(@graham35p)
Active Member Registered
Joined: 7 months ago
Posts: 6
Topic starter  

Hi,

I have just installed a Bltouch.

When I boot up the machine, with an SD card containing the new firmware, the screen stays blank, apart from the backlight. There is no sign of the blue line or Creality logo. Nothing.

The BLtouch pin goes down and up twice and the body remains glowing orange.
The nozzle cooling fan is running.
The blue LED on the motherboard is lit.
The motherboard compartment fan is not running.

I have left it switched on for at least 5 mins but nothing else happens.

I have changed the filename and also tried with different firmware versions.

I have tried disconnecting the BLtouch.

I have checked all plugs are pushed in firmly.

I have connected my laptop but the slicer software cant see it. 

I now have a very expensive ornament, as I can't do anything with it. Even if I boot it up without an SD card inserted, I get the same blank screen etc.

Does anyone have any ideas that would help?

The machine is an Ender 3 V2 and the BLtouch was purchased as a specific version for the V2, purchased from Creality.

Thanks for any advice.


ReplyQuote
Topic Tags
Eli liu
(@eli-liu)
Reputable Member Registered
Joined: 10 months ago
Posts: 462
 

firstly, you can check this video for the basics of your printer. maybe you forgot to flash the screen. Flashing a firmware is tricky. 

Creality Ender 3 V2 Firmware Update

https://forums.creality3dofficial.com/tutorial/3d-printer-basics/


ReplyQuote
Graham35p
(@graham35p)
Active Member Registered
Joined: 7 months ago
Posts: 6
Topic starter  

Hi,

Thank you for the reply.

I have now loaded the screen firmware T5UIC1_V20_4页面_191022, from the Creality website.

The machine still does exactly as described previously.

I have tried to load the mainboard firmware again but still nothing shows on the screen when I power it up.

Thanks.

Kind regards


ReplyQuote
meltdown
(@meltdown)
Active Member Registered
Joined: 7 months ago
Posts: 7
 

I am having this exact same problem except I have an Ender 3 Pro. When I plug in the burner the blue light on the motherboard turns on, but there's nothing on my computer. All the firmware that I download do nothing. 


ReplyQuote
Eli liu
(@eli-liu)
Reputable Member Registered
Joined: 10 months ago
Posts: 462
 

@graham35p I checked the video again, and it seems like no need to flash the screen(btw, screen firmware is a zip file and should be inserted into the screen sd card slot). Anyway, you need to check your BL touch version and download the according version of the firmware. 

Ender3 V2-4.2.2-32bit

Marlin-2.0.1_V1.3.1- BLTouch 

or

Ender3 V2-4.2.2-32bit

Marlin-2.0.1 – V1.1.1-BLTouch

They are different 

 


ReplyQuote
Eli liu
(@eli-liu)
Reputable Member Registered
Joined: 10 months ago
Posts: 462
 

@meltdown for 3 pro, you need to confirm your mainboard version and BL touch version first. Then we can find the right firmware.


ReplyQuote
Graham35p
(@graham35p)
Active Member Registered
Joined: 7 months ago
Posts: 6
Topic starter  

Hi,

Thank you for the reply.

I have tried loading the correct firmware but my system doesn't get far enough for the version number to make any difference.

I cannot load any main board firmware.

When I switch the printer on, with the SD card installed, the screen stays blank. Only the backlight is lit. Nothing happens with regard to loading firmware.

In all the videos I have seen, regarding firmware installation, the screen shows the Creality logo and a progress bar. I get nothing.

It seems that the machine doesn't know that it has to load the .bin file.

I have tried a number of SD cards. I have re-formatted the cards, downloaded the files from the internet a number of times, loaded screen firmware, but nothing will make the printer load the main firmware.

 

Kind regards

Graham


ReplyQuote
Eli liu
(@eli-liu)
Reputable Member Registered
Joined: 10 months ago
Posts: 462
 

@graham35p I may overlook one important thing, make sure your mainboard version is V4.2.2, and if you failed to flash the firmware once, you need to change the .bin file's name to a different one, so the printer can read it again. I think the issues here may be improper firmware installation steps or wrong firmware. Watching more video would help


ReplyQuote
Graham35p
(@graham35p)
Active Member Registered
Joined: 7 months ago
Posts: 6
Topic starter  

Hi,

I have renamed the .bin file and switched the printer on.

The display backlight comes on but nothing else shows on the display.

 

Kind regards

Graham


ReplyQuote
meltdown
(@meltdown)
Active Member Registered
Joined: 7 months ago
Posts: 7
 

@eli-liu I got it to work. I wasn't going down far enough in the zip folder to find the progisp file. 

Thanks for taking the time to respond. 


ReplyQuote
Graham35p
(@graham35p)
Active Member Registered
Joined: 7 months ago
Posts: 6
Topic starter  

I have managed to get it working, although I'm not sure what I did differently.

Creality advised me to perform all the things that have been suggested here and that I have tried in the past.

The only thing I have changed is the SD card.
I was using a 32GB SD card. I didn't use the 8GB card supplied with the machine as I was advised to have nothing on the card except the .bin file, and didn't want to wipe all the data from it.

This time however, I copied the files from the 8GB card onto my PC, formatted it and then loaded only the .bin file.

I inserted the card, switched on and after 10 seconds the Creality logo appeared.

I'm not sure if the 32GB card was not compatible with the printer for some reason. It worked OK in my PC. It's the only thing I can think of that I have done differently over the past couple of weeks.

Thank you Eli liu for your patience and help. It is very much appreciated.


Eli liu liked
ReplyQuote
breinhold
(@breinhold)
New Member Registered
Joined: 3 months ago
Posts: 2
 

@graham35p

I'm having a similar problem.  Which version of the Marlin update did you use?  I've tried 2.0.1 V1.1.2 - BLTouch as well as  V1.3.1 and have the same result.


ReplyQuote
CYT
 CYT
(@cyt)
Screw
Joined: 4 months ago
Posts: 42
 

@breinhold may I ask which printer you are using and do you know the mainboard version?

 


ReplyQuote
breinhold
(@breinhold)
New Member Registered
Joined: 3 months ago
Posts: 2
 

I have an Ender 3 Pro with the 4.2.2 board.  It seems to be a firmware issue as the BLtouch powers up (but only flashes red and does not do the test movement) and I have the blue screen of death.  I tried flashing back to the original settings but that made no difference.

FYI - this is my first 3d printer and I haven't even used it yet so please presume I know less than nothing


ReplyQuote
seajhawk
(@seajhawk)
New Member Registered
Joined: 2 months ago
Posts: 1
 
Posted by: @graham35p

The machine is an Ender 3 V2 and the BLtouch was purchased as a specific version for the V2, purchased from Creality.

I have the same configuration that graham mentioned above.

And I'm hitting the same error. 

I originally put the E3V2-BLTouch-3x3-v4.2.2.bin file on the microSD card that came with the printer. After trying to flash that way, I have the dead screen issue.

I then tried formatting the included microSD card and put just the .bin file on it. No change.

I also grabbed another 4GB microSD card that I had, formatted it, and put just the .bin file on it. No change.

Now, it looks like my printer is dead. How do I get it out of this state?


ReplyQuote
Page 1 / 2