Forum

 

BL Touch problems w...
 
Notifications
Clear all

BL Touch problems w/ 4.2.2


lashley514
(@lashley514)
New Member Registered
Joined: 8 months ago
Posts: 1
Topic starter  

Im having issues with my Ender 3 Pro and BLTouch. I have the v4.2.2 board and a v3.1 BLTouch from antclabs. Because of the 4x board I have switched the pins to the correct way of Ground(Blue), 5v (red), and Sig (Yellow). I have placed the black and white z stop cable from my BLtouch where my z stop part was by default install. I am using the Creality firmware.

When I turn the printer on the bltouch flashes red and deploys the pen then goes solid red. I can move the z access up or down by using the move axis menu. I can go into the bltouch menus and do self test, deploy and stow.

When I do auto home bltouch goes to the middle of the bed deploys and then on the controller shows "STOPPED". From this point I can no longer move the Z axis down.

What have I done wrong?

 

With this setup of BLTouch where should the 2 pin cable from the bltouch be connected to? The z stop port or next to the 3 pin addon port?


ReplyQuote
qmanblack@gmail.com
(@qmanblackgmail-com)
New Member Registered
Joined: 8 months ago
Posts: 3
 

I am having the same issue and can't figure it out

 


ReplyQuote
rezzerwrecked
(@rezzerwrecked)
New Member Registered
Joined: 2 months ago
Posts: 1
 

--The following mostly applies if you're compiling Marlin yourself. See paragraph 2 for Creality .bin download instructions. I am using an Ender 3 with a non-silent 4.2.2 board--

If you're not using the full 5pin BLTouch port you should have your 2pin cable plugged into the same port that your physical z-endstop switch was originally plugged into. You then need to make sure that the following line is uncommented

//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

IIRC this is the default behavior for Creality-released firmware. You can download the latest BLTouch compatible firmware from Creality HERE. Click "Ender Series" in the left-hand menu then select the correct file for your printer. For an Ender 3 Pro it's "Ender-3 Pro 3D Printer(Same firmware for BL-touch &CR-touch)"

I've just been working through this but with the 5 pin BLTouch 3.1 harness, so I don't know how well this will apply, but I have the start of a fix for Marlin v2.0.9. You probably will have to just use all the pins on the dedicated BLTouch header for this.

Do your standard config, then open up configuration.h and search/verify the following

1. Uncomment

#define BLTOUCH

2. Comment out the line

//#define Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN

3. Uncomment

#define USE_PROBE_FOR_Z_HOMING

4. Uncomment and edit the following to PIN PB1 (v4.2.2 board BLTouch 5pin header)

#define Z_MIN_PROBE_PIN PB1

5. To enable the Probe Offset Wizard (recommended), go into Configuration_Adv.h and uncomment

#define BABYSTEPPING
#define BABYSTEP_ZPROBE_OFFSET
#define PROBE_OFFSET_WIZARD
#define PROBE_OFFSET_WIZARD_START_Z -4.0
#define PROBE_OFFSET_WIZARD_XY_POS { 117 , 117 }

Replace "117" with the X and Y coordinates for the center of your bed. 117,117 is the center of my Ender 3 configuration, yours may be different. To calculate the center coordinates, divide the axis volume in half. Stock Ender 3 is 235x235mm. I rounded down for no particular reason since the actual center is 117.5,117.5.

 

As always, use your brain, don't trust random internet advice blindly, and be ready to turn off the PSU to prevent the nozzle from crashing while you test.

 

Here is the Teaching Tech troubleshooting website, which is an extremely useful knowledge base.

This post was modified 2 months ago 5 times by rezzerwrecked

kevin liked
ReplyQuote