Forum


 

4.2.2 board with GD…
 
Notifications
Clear all

4.2.2 board with GD32 chip, Unable to re-flash

1 Posts
1 Users
0 Likes
402 Views
daasu
(@daasu)
New Member
Joined: 5 months ago
Posts: 1
Topic starter  

I have an Ender 3 pro with a 4.2.2 board and GD32 chip.  I’ve added a BL touch and wanted to upgrade the firmware.  I was successful at flashing and loading Marlin 2.1.x with STM32F103RE environment.  The bltouch didn’t work properly and I had thought I did something wrong in the config files, so I change the file and re-flashed the board.  I did this several times trying to fix the bltouch.  After three days, I found out that I still needed the z sensor plugged in.  When I plugged that in, the bltouch worked better but not to my full expectations.  I re-flashed a few more times, but noticed nothing was changing.  I then changed the the name of my printer in the config file and that’s when i noticed I wasn’t actually re-flashing anything.

Things I’ve tried:

  1. rename the bin file. (which i don’t think matters anymore because VSC changes the name each time.)
  2. deleting everything off the SD card except the file.
  3. placing the file in a subdirectory labeled “STM32F4_UPDATE” (recommendation from a post)
  4. direct connection to my computer via USB (but VSC doesn’t support direct connect on 32 bit boards)

Things I havn’t tried:

  1. formatting the SD, because I was able to use it to flash, why shouldn’t it work to re-flash
  2. using a bigger/small SD, same reason

Follow on research leads me to believe this is a GD32 issue.  Even though I was able to originally flash with Marlin, a lot of posts say Marlin doesn’t support GD32.  Please help!

 


   
ReplyQuote