CR-6-SE-V2.0.1.3-En...
 
Notifications
Clear all

CR-6-SE-V2.0.1.3-English-update-firmware

Page 6 / 10

tom
 tom
(@tom)
New Member Registered
Joined: 7 months ago
Posts: 3
 

Hi folks,

updated mine a few hours ago. Has worked right from the start. Check the video for the update to .2, it's similar to .3. Some minor hints/tips/impressions, I wasn't sure from the start. 

  • I used a 2 GB micro SD card for the display update. FAT-32 file system. I've extracted the zip which contains both, printer & display update, using windows native functions. No WinZip, nor 7Zip. On my Mac the filenames of three file are different after the extraction as on windows. There's a post about it in the ".2" thread. For me the version "13┤Ñ┐╪┼Σ╓├╬─╝■.bin" of one if the files was working. Maybe they, Creality, should consider to rename those files, but maybe that isn't possible because of the root loader.
  • Still the display update: Copy the complete "DWIN_SET" folder to the SD card, not only the content. As a folder with the name "DWIN_SET". The folder is then the only item in the root directory of the card. I'm not sure if that is working from macOS, because that OS creates two or three dot folders.
  • Flash the display: Wait for that "END !" in the upper right corner until you shut down the display power. Not all "Download" counts are not zero, but a few are. Don't worry. Check the attach picture.
  • I've used the SD card I usually use for printing to do the flashing of the main printer firmware. Simply copied that "CR-6SE - V2.0.1.3 - HW - V4.5.2.bin" to the card, inserted it, and powered up the printer. Along with all the other files on the card. Took only a few seconds, 20-30 or so.

BTW: The older firmware "1.x" starts with an updated display. But shows only screens in Chinese. Not sure anymore if you see values, settings, numbers, or only the blank screen. Navigation was possible. But when you try to set the language the printer freezes. So either you update both, display and main, or nothing.

Anyway, no flaw until now. Printer works as before, bed level settings are fine, no bed new levelling done. No further differences that cosmetic, new languages.

Flaws in some prints are still there. Sometimes the machine simply "forgets" to output material. 

This post was modified 7 months ago 2 times by tom

ReplyQuote
akikiki
(@akikiki)
Eminent Member Registered
Joined: 7 months ago
Posts: 28
 

While trying to update my firmware from 1.0.3.6 to newer I guess that I removed the screen and opened it 12+ times. There's got to be a better way.  So, I looked for a handy-dandy thing to help. I found this on Amazon and ordered it. I opened the screen up one more time and plugged it in. The ribbon cable is just long enough to come out, and around to the top and with a small piece of two sided tape hold it on the screen. Now I have easy access to insert the micro SD card when I need to.

Micro SD Memory card Male/Female Extension entender


ReplyQuote
Gypaete
(@gypaete)
Active Member Registered
Joined: 7 months ago
Posts: 17
 

@tom

Hello Tom,
you have also successfully completed this update like many CR-6SE users, having applied the recommendations on the subject of this CR-6SE update - V2.0.1.3.

However, as I mentioned above, this does not explain the difference in the version of the screen update between the documented version V3.4 (Upgrade Guide for CR-6 Series Printer) which is dated June 2020 and the one we had installed which is V1.4 2019.04.18.

Hence my question to Creality R%D through Eli Liu to confirm that all the announced improvements are indeed present in this version V1.4. of April 2019.

 


ReplyQuote
louisvantonder
(@louisvantonder)
New Member Registered
Joined: 7 months ago
Posts: 1
 

For all those that had issues updating the screen... I just figured it out. After hours of trying...

The Screen firmware folder, has been zipped from an initial folder, not files. So when you extract the "DWIN_SET" folder, it has another "DWIN_SET" folder inside it...

DWIN_SET/DWIN_SET/* (files)

You need to have a folder 1 level deep, on the SD.

So, make sure you have... SD:/DWIN_SET, and not

SD:/DWIN_SET/DWIN_SET 

Hope this helps someone.


cnytkptn liked
ReplyQuote
cnytkptn
(@cnytkptn)
New Member Registered
Joined: 7 months ago
Posts: 1
 

@louisvantonder thank you my firend. I figured it out with your help. I used 32 kb. It wasnt worked then ı tried with format  4096 and it is done. While updating before the seeing END , The screen shuted down. Dont worry. Then I cut the power and power up again without SD Card . Everthing was ok.

 

It is working.


ReplyQuote
tom
 tom
(@tom)
New Member Registered
Joined: 7 months ago
Posts: 3
 

For seven days my printer now works with the 2.0.1.3 firmware. But was it worth it, the update?

Some thoughts:

  • I do have a couple of files, sliced with Cura (MaxOS), which don't print correctly. Still. It appears that the printer didn't start at all or stuttering material output after a layer change. Nope, not nice.
  • The english translation is worse. Now. Before it was ok. What was wrong with "Prepare"? Now it's named "Ready". Or "Tune", that was fine. Now it's called "Setup" how weird is that? There are a couple of more examples. Now the printed manual and the screens didn't match anymore, btw.
  • After a finished print the bed now moves fully to the front. And not to the back anymore, never understood that move. Nice. But in now way a game changer.
  • Nothing broken for me, can't say if "vase mode" is, I don't use it.
  • Maybe writing layer information to the SD card when changing layers is fixed. Never had an issue with this. Beside the fact that resume the print after a failure, that is why the info is necessary, is a useless feature. Yes, sometimes it works. Usually not. My two cents.

Was it worth it? When you look at the procedure to update the display firmware, disassembling and so on, the slight problem with the file names, and last but not least the risk of breaking your printer:

No. 

Regards,

Tom


ReplyQuote
Sam
 Sam
(@sam)
New Member Registered
Joined: 7 months ago
Posts: 2
 

After upgraded, the machine is not functioning.


ReplyQuote
con2olecowboy
(@con2olecowboygmail-com)
New Member Registered
Joined: 7 months ago
Posts: 2
 

Howdy. I'm having an issue with my printer.
 I updated the firmware as instructed and all my menus were in Chinese. After researching I found the solution was to update the screen firmware as well. After i do this my printer now freezes on the bootscreen with the creality logo and an empty loading bar. Any way to fix this?


ReplyQuote
con2olecowboy
(@con2olecowboygmail-com)
New Member Registered
Joined: 7 months ago
Posts: 2
 

Update: I fixed the issue by using a custom firmware for both the printer and the screen. Found here ( https://github.com/CR6Community). Probably not for everyone, but it worked for me.


ReplyQuote
peachynoonoo
(@peachynoonoo)
New Member Registered
Joined: 7 months ago
Posts: 1
 

is this for the 32bit board?, I just got my cr6-se and want to make sure im upto date with firmware im currently on v1.0.3.2. this is my first creality printer and im pretty impressed so far but I want to be able to do filament changes as I have files waiting to print which have been ordered, has anyone tested the M600 M25 and had success??


ReplyQuote
gmueller2000
(@gmueller2000)
New Member Registered
Joined: 6 months ago
Posts: 1
 

I had the same problem with the chines font. Guess what my problem was ... RTFM

I just used the same slot and sd card as the standard firmware upgrade but didn' recognize that it had to be done with a different sd card and an unmounted display ...


ReplyQuote
mpbourque67
(@mpbourque67)
New Member Registered
Joined: 6 months ago
Posts: 2
 

@eli-liu I noticed that after the upgrading both firmware and screen to 2.0.1.3 that even though I select english, I see no english only icons. My question if this is right? I don't mind, but I do not know what all the icons are. Can you explain if something is wrong?


ReplyQuote
nicwilson
(@nicwilson)
New Member Registered
Joined: 6 months ago
Posts: 3
 

@eli-liu Can you please provide a link to the source code for the V2.0.1.3 firmware you have released as you are required to do upon request under the GPL license terms.  I want to make a few changes to this firmware and compile a version of it but cannot without the source code.

 

cheers

nicw


ReplyQuote
nicwilson
(@nicwilson)
New Member Registered
Joined: 6 months ago
Posts: 3
 

@mpbourque67 I would do it again and make sure you are using the correct files,  I just updated to 2.0.1.3 and also did the display and languages work fine,   they did not however prior to the display update, so I would check this was done correctly with the correct files.


akikiki liked
ReplyQuote
mpbourque67
(@mpbourque67)
New Member Registered
Joined: 6 months ago
Posts: 2
 

Will try again, I should mention I had the problem with the release that was NOT marked (REVOKED). The problem goes away however on the revoked version. Which did you use? I tried multiple times.


ReplyQuote
Page 6 / 10