Forum

 

stepper motor probl...
 
Notifications
Clear all

stepper motor problem on CR-10 v3


cparsons
(@cparsons)
New Member Registered
Joined: 10 months ago
Posts: 1
Topic starter  

I am having a problem with my x-axis stepper motor on my CR-10 v3. When I try to home, Y and Z work, but X does not. And when I just try to move it 1mm at a time, it moves twice (more like it jerks twice) then stops moving. Then it will do that again if I turn the machine off and back on again. I took off the motor and plugged it into the y-axis, and tried the same thing, and the motor worked perfectly, so I know the issue is not with the motor. Then I thought maybe it could be the limit switch, so I swapped out the limit switch on the x-axis for an extra one that came with the printer, and that didn't change anything (I suppose that one could be broken too?).

I tried re-flashing the firmware, and that seems to have changed nothing. I don't have a BLTouch on this machine yet by the way, and I'm using the firmware that leaves that out (not that I think that has anything to do with this).

Anyone have any ideas?


ReplyQuote