Tuning E steps issu...
 
Notifications
Clear all

Tuning E steps issue and firmware issue

Page 1 / 2

wmcwilli
Posts: 7
Registered
Topic starter
(@wmcwilli)
Nozzle
Joined: 3 months ago

I seem to be having some issues after flashing new firmware. My Ender 3 v2 came from amazon ( https://www.amazon.com/gp/product/B07FFTHMMN/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1). Being as it has the silent motherboard I assumed it's the 4.2.7 board. When I try and load the firmware for that full setup the machine will not home. When I load the firmware for the stock ender 3 v2 everything seems to work so for now I will be sticking with that. I will be adding a BL touch tomorrow so I can verify the board then. I was going to do it today but the bracket for the hot end was not tapped from the factory for the screws for the BL Touch so I have to wait for my tap set to show up.

My second issue is that while trying to calibrate my extruder e steps I can only go up by .1 at a time before it deselects that setting and scrolls through the list. This is a major issue because I have a dual gear extruder and that requires upping it from the default 97 up to 140.... That means I have to click the button 430 times to get to the proper rate. This also happens during a print when I try to adjust the hot end temp or the surface temp.

My last issue is that when I try to build a custom firmware it just fails. No warning or anything about why. I want to make my build plate 235 x 235 instead of 225 x 225 since that's the more usable size.

Reply
13 Replies
Marlin Firmware Service
Posts: 189
(@marlin-firmware-service)
Stepper Motor
Joined: 4 months ago

Hi Wes,

Unless you've changed the board from the stock board, your printer likely shipped with a v4.2.2 mainboard. Loading firmware for a v4.2.7 board won't work and will lead to lots of problems.

This video might help you understand the difference between boards etc:

You can confirm the version of the mainboard you have by looking at the white text printed on the mainboard.

If you are looking at changing e-steps, normally this is set in your slicers Start G-code as the command:

M92 E140

This will change your printer e-steps to 140. The menu is only really intended to be used for small adjustments. This is documented here: https://marlinfw.org/docs/gcode/M092.html

Reply
wmcwilli
Posts: 7
Registered
Topic starter
(@wmcwilli)
Nozzle
Joined: 3 months ago

I definitely do have the 4.2.2 board and did end up flashing that firmware. The problem with adjusting settings still persists. With the OEM firmware it would let me scroll through to the desired number and then clicking the knob down to set that value. This issue is also applied to jogging any of the steppers. Therefore if I want to jog forward the extruder to properly calibrate e steps I have to scroll the wheel .1 at a time till I reach 100 with also me needing to click on that setting between each adjustment of .1mm

 

I also have the BL touch installed now. Everywhere on the internet shows a BL touch with two plugs. One with the 3 colored wires and one with just the black and white. The one I received is all 5 wires on one plug.

Reply
Marlin Firmware Service
Posts: 189
(@marlin-firmware-service)
Stepper Motor
Joined: 4 months ago
Posted by: @wmcwilli

The problem with adjusting settings still persists.

I just checked this on my printer, and it doesn't do that. I can press down on the value to select it, then scroll either way and press again to activate that value. Which firmware file did you flash? I'll check it again on my printer (also a v4.2.2 board).

Posted by: @wmcwilli

The one I received is all 5 wires on one plug.

This is fine. If it fits in the probe port, then that's an easy fit. The probe port is labelled as G V IN G OUT on the mainboard. Picture in the following link:

https://marlin.crc.id.au/faq/Ender%203%20V2/#bltouch

You'll also need to follow the next item in to how to set your Z-Offset. There's a video on how to do that effectively.

Reply
wmcwilli
Posts: 7
Registered
Topic starter
(@wmcwilli)
Nozzle
Joined: 3 months ago
Here is a video to better show my issues that I am experiencing 
Reply
1 Reply
wmcwilli
Registered
(@wmcwilli)
Joined: 3 months ago

Nozzle
Posts: 7

Upload failed because of file size. Uploading to my google drive now.

Reply
Page 1 / 2
Scroll Up