Idle timeout overri...
 
Notifications
Clear all

Idle timeout overriding Preheat orders


jeferod83
Posts: 5
Registered
Topic starter
(@jeferod83)
Active Member
Joined: 2 months ago

Hi devs and enthusiasts!

When I was with the stock Ender 3 V2 firmware, and when I had called the option to preheat ABS or PLA, it stayed heating with the configured temps until I want, being print anything or to cooldown, but I decide what to do.

After uploading a Marlin firmware (build 20210305), the cooldown order is overriding my preheat order, even before reaching the temps configured, it stops the heat. In other words, the idle timeout is disregarding the preheat order.

My printer is a Ender 3 V2 with Marlin V4.2.2 board.

I believe this is a bug. This is the way to make a request to fix this problem?

I'm new in this forum and I loving 3D printing, and if I can make this community better, I'll do.

Thanks a lot!

(sorry for my bad english)

Reply
6 Replies
Marlin Firmware Service
Posts: 199
(@marlin-firmware-service)
Estimable Member
Joined: 6 months ago

The values for the timeout are to protect your printer from burning the filament in the hotend etc.

This should be 'fixed' in the start g-code in your slicer.

See the FAQ for the Ender 3 V2 under the title: "What is the recommended Start G-Code?"

Reply
5 Replies
jeferod83
Registered
(@jeferod83)
Joined: 2 months ago

Active Member
Posts: 5

I understand @marlin-firmware-service

When I sed that I ordered to preheat is from the printer panel, not from gcode made on my slicer.

I believe the correct form to begin the idle timeout counter is from a start flag that is started when the heat target configs are reached. No?

Thanks for the quickly reply!

Regards,

Jeferson

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 6 months ago

Estimable Member
Posts: 199

@jeferod83 I'm not sure what you mean.

The idle timeout is based on lack of movement from the steppers.

Reply
jeferod83
Registered
(@jeferod83)
Joined: 2 months ago

Active Member
Posts: 5

@marlin-firmware-service

I'll try to explain, step to step.

First of all, I work on the model. A few time before finalize it, I turn on my 3d printer, and, from its panel, I ask to "preheat abs". The target temps are 240° and 110° for the hotend and bed, respectively.

At this moment, I finalize my model, slice it and generate the gcode, put it on a sd card, and on the printer, and finally I ask to start the print job.

The hotend heats more easily, and reach the work temp mutch faster than the bed. So, the idle timeout are reached and stop the bed heating, and it begins to cooldown, even if configured in preheating and gcode, it stops the heating of the bed, and I need to correct on the "Tune" menu on panel.

I hope to explained it well to you.

Regards,

Jeferson

Reply
Marlin Firmware Service
(@marlin-firmware-service)
Joined: 6 months ago

Estimable Member
Posts: 199

@jeferod83 Yes - likely things are heating too slow - especially trying to push the bed to 110c... You would need to use the start g-code from the FAQ to resolve this.

Reply
jeferod83
Registered
(@jeferod83)
Joined: 2 months ago

Active Member
Posts: 5

@marlin-firmware-service

If I understood, do you recommends to heat the printer from gcode (starting the print of my model) instead of preheat from the printer panel?

I look the FAQ and I'll put the start codes on my slicer. There was a lot of good tips on it. Thanks for the tip!

Regards,

Jeferson

Reply
Scroll Up