Notifications
Clear all

BL Touch not producing desired results?


edwil55
(@edwil55)
New Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

I recently bought an Ender 3 V2 printer and added a BL Touch sensor.  Per the instructions I updated the firmware to V1.1.1,  menu now shows the option to level the bed and have gone through the leveling process a couple of times now and have also adjusted the Z offset set at 3.10 mm.   Also have upgraded the springs and leveling wheels.  It has the glass bed which is said to normally be pretty flat.

 

Twice now I’ve tried printed leveling squares with similar bad results.  Per the attached photo, every time the right side, in particular the front looks terrible.  Not sure if the nozzle is too close to the bed or too  far, I’m leaning towards too close??  I could adjust the front right spring, but my understanding of how the sensor works, It should compensate for my adjustment and produce the same result?

 

I also did manually level the bed prior, didn’t attempt to get it perfect as assumed the touch sensor would take care of any slight misalignments, but it certainly isn’t off by a huge amount.  From what I can measure the springs are compressed around 5mm from their initial 20mm free length.  After removing the squares off the bed I measured them; the ones on left and center are in the range of .25 to .35 mm thick, right side are around .10 mm thick.  None are perfectly smooth on the top either.

 

After Auto Homing, heating the bed, and running the bed leveling routine, I brought the Z axis down to zero, with the applied Z offset and moving the bed around to all nine positions, the nozzle is approximately .10 mm away from the bed. (slightly greater than a sheet of paper)  Is that maybe still too far?  Does my Z offset seem higher than normally found with the sensor?

 

Am I missing something as to what/how the sensor is supposed to work, shouldn’t the sensor be taking care of any alignment issues and produce a flat part?


ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@edwil55 I got BLtouch for my ender3 v2 as well, but I still need to manually adjust the flatness of the hotbed. Because BL-touch seems can only do some adjustment slightly.


ReplyQuote
edwil55
(@edwil55)
New Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

One other thing I'll add that I noticed.  After installing the sensor and going through the Auto-Home routine, the nozzle is raised up 10mm.  Sop went into the move menu and lowered it to zero.  From there I  determined the Z-Offset.  Then once you enter a number for the Offset, I went back and Auto-Homed again. Now when you go into the move position, the Z axis is now 10mm from absolute zero (as expected) + the amount you entered for the Z-Offset (also as expected) but then takes .20mm away from the total.

 

Don't understand that part, should it be doing that and why.  In other words if my offset is 2.50 mm, after setting that and Auto-Homing I'm now 12.30mm away from zero. 10.0 + 2.50(offset) -.20 (why??) = 12.30.  If I now added .30 to the Offset for a total of 2.80mm, after homing, I'll now be 2.60 away from zero.

 

Any explanation??


ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@edwil55 Here is the best explanation for Z-offset. In my opinion, Z-offset should be negative as the BL-TOUCH probe is always lower than the nozzle. 

youtube.com/watch?v=fN_ndWvXGBQ&t=454s


ReplyQuote
edwil55
(@edwil55)
New Member Registered
Joined: 2 months ago
Posts: 3
Topic starter  

@kevin

Yes my Z-Offset is negative.  I neglected to explicitly specify that in my post

BTW, that You-Tube link you listed doesn't appear to be working


ReplyQuote
kevin
(@kevin)
Prominent Member Admin
Joined: 5 months ago
Posts: 900
 

@edwil55 Can not explain it. You have to look at the commands in your firmware. But when I auto home, my ender3v2 always back to Z=12.5 no matter what the Z-offset is. 


ReplyQuote